blob: b17fc67e0aee74eb82d42da5f32b9720048250f6 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001DESCRIPTION = "Tiny XML Library"
Brad Bishop19323692019-04-05 15:28:33 -04002LICENSE = "Apache-2.0"
3LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08004HOMEPAGE = "https://www.msweet.org/mxml/"
5BUGTRACKER = "https://github.com/michaelrsweet/mxml/issues"
6
7SRC_URI = "git://github.com/michaelrsweet/mxml.git"
Brad Bishop19323692019-04-05 15:28:33 -04008SRCREV = "c7755b6992a2afdd34dde47fc9be97f1237cfded"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08009S = "${WORKDIR}/git"
Brad Bishop19323692019-04-05 15:28:33 -040010# v3.0
11PV = "3.0"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080012
13CONFIGUREOPTS = " --prefix=${prefix} \
14 --bindir=${bindir} \
15 --sbindir=${sbindir} \
16 --libexecdir=${libexecdir} \
17 --datadir=${datadir} \
18 --sysconfdir=${sysconfdir} \
19 --sharedstatedir=${sharedstatedir} \
20 --localstatedir=${localstatedir} \
21 --libdir=${libdir} \
22 --includedir=${includedir} \
23 --oldincludedir=${oldincludedir} \
24 --infodir=${infodir} \
25 --mandir=${mandir} \
26 --host=${TARGET_SYS} \
27 --build=${BUILD_SYS} \
28 ${PACKAGECONFIG_CONFARGS} \
29 "
30
31do_configure() {
Brad Bishop19323692019-04-05 15:28:33 -040032 install -m 0755 ${STAGING_DATADIR_NATIVE}/gnu-config/config.guess ${S}
33 install -m 0755 ${STAGING_DATADIR_NATIVE}/gnu-config/config.sub ${S}
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080034 ./configure ${CONFIGUREOPTS} --enable-shared
35}
36
37do_install () {
38 export DSTROOT=${D}
39 oe_runmake install
40}
41
42PACKAGES += " ${PN}-bin "
43FILES_${PN} = "${libdir}/*"
44FILES_${PN}-bin = "${bindir}/*"