blob: 68409c9103252954cb2d3a52d9dae2f5b9510562 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Netfilter Tables userspace utillites"
2SECTION = "net"
3LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://COPYING;md5=d1a78fdd879a263a5e0b42d1fc565e79"
5
6DEPENDS = "libmnl libnftnl bison-native \
7 ${@bb.utils.contains('PACKAGECONFIG', 'mini-gmp', '', 'gmp', d)}"
8
9# Ensure we reject the 0.099 version by matching at least two dots
10UPSTREAM_CHECK_REGEX = "nftables-(?P<pver>\d+(\.\d+){2,}).tar.bz2"
11
12SRC_URI = "http://www.netfilter.org/projects/nftables/files/${BP}.tar.bz2"
Andrew Geisslerd159c7f2021-09-02 21:05:58 -050013SRC_URI[sha256sum] = "58bf547daf967a2b88ecb4f425f126006ebde22711db806b25c1d6cf84fe45f4"
Andrew Geissler82c905d2020-04-13 13:39:40 -050014
15inherit autotools manpages pkgconfig
16
Andrew Geisslereef63862021-01-29 15:58:13 -060017PACKAGECONFIG ??= "python readline json"
Andrew Geissler82c905d2020-04-13 13:39:40 -050018PACKAGECONFIG[json] = "--with-json, --without-json, jansson"
19PACKAGECONFIG[manpages] = "--enable-man-doc, --disable-man-doc, asciidoc-native"
20PACKAGECONFIG[mini-gmp] = "--with-mini-gmp, --without-mini-gmp"
21PACKAGECONFIG[python] = "--enable-python --with-python-bin=${PYTHON}, --with-python-bin="", python3"
22PACKAGECONFIG[readline] = "--with-cli=readline, --without-cli, readline"
23PACKAGECONFIG[xtables] = "--with-xtables, --without-xtables, iptables"
24
25inherit ${@bb.utils.contains('PACKAGECONFIG', 'python', 'python3native', '', d)}
26
Patrick Williams213cb262021-08-07 19:21:33 -050027RRECOMMENDS:${PN} += "kernel-module-nf-tables"
Andrew Geissler82c905d2020-04-13 13:39:40 -050028
29PACKAGES =+ "${PN}-python"
Patrick Williams213cb262021-08-07 19:21:33 -050030FILES:${PN}-python = "${nonarch_libdir}/${PYTHON_DIR}"
31RDEPENDS:${PN}-python = "python3-core python3-json ${PN}"