blob: fb83361856885f5b5020b7febb739eacd4247980 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "A library to abstract stream I/O like serial port, TCP, telnet, etc"
2HOMEPAGE = "https://github.com/cminyard/gensio"
3LICENSE = "GPL-2.0 & LGPL-2.1"
4LIC_FILES_CHKSUM = "file://COPYING.LIB;md5=a0fd36908af843bcee10cb6dfc47fa67 \
5 file://COPYING;md5=bae3019b4c6dc4138c217864bd04331f \
6 "
7
Andrew Geisslerd159c7f2021-09-02 21:05:58 -05008SRCREV = "343ccf17ce656203b6b5513f4b7962f45d37b589"
Andrew Geissler82c905d2020-04-13 13:39:40 -05009
Andrew Geisslerac970dd2021-02-12 15:32:45 -060010SRC_URI = "git://github.com/cminyard/gensio;protocol=https;branch=2.2.x"
Andrew Geissler82c905d2020-04-13 13:39:40 -050011
12S = "${WORKDIR}/git"
13
14inherit autotools
15
16PACKAGECONFIG ??= "openssl tcp-wrappers"
17
18PACKAGECONFIG[openssl] = "--with-openssl=${STAGING_DIR_HOST}${prefix},--without-openssl, openssl"
19PACKAGECONFIG[tcp-wrappers] = "--with-tcp-wrappers,--without-tcp-wrappers, tcp-wrappers"
20PACKAGECONFIG[swig] = "--with-swig,--without-swig, swig"
21
22EXTRA_OECONF = "--without-python"
23
Patrick Williams213cb262021-08-07 19:21:33 -050024RDEPENDS:${PN} += "bash"