blob: 32484ce7910f11a2a9fc661e4ef4c9f54c6d7e1e [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "gd is a library used to create PNG, JPEG, or WBMP images"
2DESCRIPTION = "The gd graphics library allows your code to quickly draw images \
3complete with lines, arcs, text, multiple colors, cut and paste from other \
4images, and flood fills, and to write out the result as a PNG or JPEG file. \
5This is particularly useful in Web applications, where PNG and JPEG are two \
6of the formats accepted for inline images by most browsers. Note that gd is not \
7a paint program."
8HOMEPAGE = "http://libgd.github.io/"
9
10SECTION = "libs"
11LICENSE = "GD"
12LIC_FILES_CHKSUM = "file://COPYING;md5=8e5bc8627b9494741c905d65238c66b7"
13
14DEPENDS = "freetype libpng jpeg zlib tiff"
15
16SRC_URI = "git://github.com/libgd/libgd.git;branch=master \
Andrew Geisslerf103a7f2021-05-07 16:09:40 -050017 file://0001-replace-uint32-with-uint32_t-and-uint16-with-uint16_.patch \
Andrew Geisslerd159c7f2021-09-02 21:05:58 -050018 file://0001-fix-read-out-of-bands-in-reading-tga-header-file.patch \
Andrew Geisslerf103a7f2021-05-07 16:09:40 -050019 "
Andrew Geissler82c905d2020-04-13 13:39:40 -050020
Andrew Geissler32b11992021-03-31 13:37:05 -050021SRCREV = "2e40f55bfb460fc9d8cbcd290a0c9eb908d5af7e"
Andrew Geissler82c905d2020-04-13 13:39:40 -050022
23S = "${WORKDIR}/git"
24
25inherit autotools binconfig gettext pkgconfig
26
27EXTRA_OECONF += " --disable-rpath \
28 --with-jpeg=${STAGING_LIBDIR}/.. \
29 --with-freetype=yes \
30 --without-fontconfig \
31 --without-webp \
32 --without-xpm \
33 --without-x \
34 "
35
36EXTRA_OEMAKE = 'LDFLAGS="${LDFLAGS}"'
37
Patrick Williams213cb262021-08-07 19:21:33 -050038DEBUG_OPTIMIZATION:append = " -Wno-error=maybe-uninitialized"
Andrew Geissler82c905d2020-04-13 13:39:40 -050039
Patrick Williams213cb262021-08-07 19:21:33 -050040do_install:append:class-target() {
Andrew Geissler82c905d2020-04-13 13:39:40 -050041 # cleanup buildpaths from gdlib.pc
42 sed -i -e 's#${STAGING_DIR_HOST}##g' ${D}${libdir}/pkgconfig/gdlib.pc
43}
44
45PACKAGES += "${PN}-tools"
46
Patrick Williams213cb262021-08-07 19:21:33 -050047FILES:${PN} = "${libdir}/lib*${SOLIBS}"
48FILES:${PN}-tools = "${bindir}/*"
Andrew Geissler82c905d2020-04-13 13:39:40 -050049
50PROVIDES += "${PN}-tools"
Patrick Williams213cb262021-08-07 19:21:33 -050051RPROVIDES:${PN}-tools = "${PN}-tools"
52RDEPENDS:${PN}-tools = "perl perl-module-strict"
Andrew Geissler82c905d2020-04-13 13:39:40 -050053
54CVE_PRODUCT = "libgd"
Andrew Geissler89770b02020-06-13 10:40:47 -050055
56BBCLASSEXTEND = "native nativesdk"