blob: d49b2cd5eb307f35c1bcf59f620fc806c914f1d0 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Perl library for transparent SSL"
2DESCRIPTION = "This module is a true drop-in replacement for IO::Socket::INET that \
3uses SSL to encrypt data before it is transferred to a remote server \
4or client. IO::Socket::SSL supports all the extra features that one \
5needs to write a full-featured SSL client or server application: \
6multiple SSL contexts, cipher selection, certificate verification, and \
7SSL version selection. As an extra bonus, it works perfectly with \
8mod_perl."
9HOMEPAGE = "http://search.cpan.org/dist/IO-Socket-SSL/"
10SECTION = "libs"
11
12LICENSE = "Artistic-1.0|GPLv1+"
13LIC_FILES_CHKSUM = "file://META.yml;beginline=12;endline=12;md5=963ce28228347875ace682de56eef8e8"
14
Patrick Williams213cb262021-08-07 19:21:33 -050015RDEPENDS:${PN} += "\
Andrew Geissler82c905d2020-04-13 13:39:40 -050016 libnet-ssleay-perl \
17 perl-module-autoloader \
18 perl-module-scalar-util \
19 perl-module-io-socket \
20"
21
22SRC_URI = "http://search.cpan.org/CPAN/authors/id/S/SU/SULLR/IO-Socket-SSL-${PV}.tar.gz \
23 file://run-ptest \
24 "
Andrew Geisslerd159c7f2021-09-02 21:05:58 -050025SRC_URI[sha256sum] = "b5bee81db3905a9069340a450a48e1e1b32dec4ede0064f5703bafb9a707b89d"
Andrew Geissler82c905d2020-04-13 13:39:40 -050026
27S = "${WORKDIR}/IO-Socket-SSL-${PV}"
28
29inherit cpan ptest
30
Patrick Williams213cb262021-08-07 19:21:33 -050031do_install:append () {
Andrew Geissler82c905d2020-04-13 13:39:40 -050032 mkdir -p ${D}${docdir}/${PN}/
33 cp ${S}/BUGS ${D}${docdir}/${PN}/
34 cp ${S}/Changes ${D}${docdir}/${PN}/
35 cp ${S}/README ${D}${docdir}/${PN}/
36 cp -pRP ${S}/docs ${D}${docdir}/${PN}/
37 cp -pRP ${S}/certs ${D}${docdir}/${PN}/
38 cp -pRP ${S}/example ${D}${docdir}/${PN}/
39}
40
41do_install_ptest () {
42 cp -r ${B}/t ${D}${PTEST_PATH}
43 cp -r ${B}/certs ${D}${PTEST_PATH}
44}
45
46BBCLASSEXTEND = "native"