blob: 74ae6cf69d2b7a2c95cc0cea7340f24f573ecf7b [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001SUMMARY = "A coroutine-based Python networking library"
2DESCRIPTION = "gevent is a coroutine-based Python networking library that uses greenlet to provide \
3a high-level synchronous API on top of the libevent event loop."
4HOMEPAGE = "http://www.gevent.org"
5LICENSE = "MIT & Python-2.0 & BSD"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=4de99aac27b470c29c6c309e0c279b65 \
Brad Bishop19323692019-04-05 15:28:33 -04007 file://NOTICE;md5=18108df3583462cafd457f024b9b09b5 \
8 file://deps/libev/LICENSE;md5=d6ad416afd040c90698edcdf1cbee347 \
9 "
Brad Bishopd7bf8c12018-02-25 22:55:05 -050010DEPENDS += "libevent"
11DEPENDS += "${PYTHON_PN}-greenlet"
Patrick Williams213cb262021-08-07 19:21:33 -050012RDEPENDS:${PN} = "${PYTHON_PN}-greenlet \
Brad Bishopd7bf8c12018-02-25 22:55:05 -050013 ${PYTHON_PN}-mime \
14 ${PYTHON_PN}-pprint \
Brad Bishopd7bf8c12018-02-25 22:55:05 -050015 "
16
Patrick Williams213cb262021-08-07 19:21:33 -050017FILESEXTRAPATHS:prepend := "${THISDIR}/python-gevent:"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050018
Patrick Williams213cb262021-08-07 19:21:33 -050019SRC_URI:append = " \
Brad Bishopd7bf8c12018-02-25 22:55:05 -050020 file://libev-conf.patch;patch=1;pnum=1 \
21"
22
Andrew Geisslerd159c7f2021-09-02 21:05:58 -050023SRC_URI[sha256sum] = "43e93e1a4738c922a2416baf33f0afb0a20b22d3dba886720bc037cd02a98575"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050024
25# The python-gevent has no autoreconf ability
26# and the logic for detecting a cross compile is flawed
27# so always force a cross compile
Patrick Williams213cb262021-08-07 19:21:33 -050028do_configure:append() {
Brad Bishopd7bf8c12018-02-25 22:55:05 -050029 sed -i -e 's/^cross_compiling=no/cross_compiling=yes/' ${S}/deps/libev/configure
30 sed -i -e 's/^cross_compiling=no/cross_compiling=yes/' ${S}/deps/c-ares/configure
31}
32
Andrew Geisslerd688a012020-09-18 13:36:00 -050033inherit pypi setuptools3