blob: 04f5760b761b5212e5a3255cb3618cc95feb1f3d [file] [log] [blame]
Andrew Geissler475cb722020-07-10 16:00:51 -05001SUMMARY = "Small library that defines common error values for all GnuPG components"
Andrew Geissler90fd73c2021-03-05 15:25:55 -06002DESCRIPTION = "Contains common error codes and error handling functions used by GnuPG, Libgcrypt, GPGME and more packages. "
Andrew Geissler475cb722020-07-10 16:00:51 -05003HOMEPAGE = "http://www.gnupg.org/related_software/libgpg-error/"
4BUGTRACKER = "https://bugs.g10code.com/gnupg/index"
5
6LICENSE = "GPLv2+ & LGPLv2.1+"
7LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552 \
8 file://COPYING.LIB;md5=2d5025d4aa3495befef8f17206a5b0a1 \
9 file://src/gpg-error.h.in;beginline=2;endline=18;md5=d82591bc81561f617da71e00ff4a9d79 \
10 file://src/init.c;beginline=2;endline=17;md5=f01cdfcf747af5380590cfd9bbfeaaf7 \
11 "
12
13
14SECTION = "libs"
15
16UPSTREAM_CHECK_URI = "https://gnupg.org/download/index.html"
17SRC_URI = "${GNUPG_MIRROR}/libgpg-error/libgpg-error-${PV}.tar.bz2 \
18 file://pkgconfig.patch \
19 file://0001-Do-not-fail-when-testing-config-scripts.patch \
William A. Kennington IIIac69b482021-06-02 12:28:27 -070020 file://fix-cross.patch \
21 file://0001-configure.ac-do-not-hardcode-gnu-libc-when-generatin.patch \
Andrew Geissler475cb722020-07-10 16:00:51 -050022 "
23
William A. Kennington IIIac69b482021-06-02 12:28:27 -070024SRC_URI[sha256sum] = "fc07e70f6c615f8c4f590a8e37a9b8dd2e2ca1e9408f8e60459c67452b925e23"
Andrew Geissler475cb722020-07-10 16:00:51 -050025
26BINCONFIG = "${bindir}/gpg-error-config"
27
28inherit autotools binconfig-disabled pkgconfig gettext multilib_header multilib_script
29
30MULTILIB_SCRIPTS = "${PN}-dev:${bindir}/gpgrt-config"
31
32CPPFLAGS += "-P"
33
Patrick Williams213cb262021-08-07 19:21:33 -050034do_install:append() {
Andrew Geissler475cb722020-07-10 16:00:51 -050035 # we don't have common lisp in OE
36 rm -rf "${D}${datadir}/common-lisp/"
37 oe_multilib_header gpg-error.h gpgrt.h
38}
39
Patrick Williams213cb262021-08-07 19:21:33 -050040FILES:${PN}-dev += "${bindir}/gpg-error"
41FILES:${PN}-doc += "${datadir}/libgpg-error/errorref.txt"
Andrew Geissler475cb722020-07-10 16:00:51 -050042
43BBCLASSEXTEND = "native nativesdk"