blob: 6b79a3b040b25433867d57a9196fa5ecc86c9085 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Random number generator daemon"
2DESCRIPTION = "Check and feed random data from hardware device to kernel"
3AUTHOR = "Philipp Rumpf, Jeff Garzik <jgarzik@pobox.com>, \
4 Henrique de Moraes Holschuh <hmh@debian.org>"
5HOMEPAGE = "https://github.com/nhorman/rng-tools"
6BUGTRACKER = "https://github.com/nhorman/rng-tools/issues"
7LICENSE = "GPLv2"
8LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
Andrew Geissler4ed12e12020-06-05 18:00:41 -05009DEPENDS = "sysfsutils openssl"
Andrew Geissler82c905d2020-04-13 13:39:40 -050010
Andrew Geisslerd159c7f2021-09-02 21:05:58 -050011SRC_URI = "git://github.com/nhorman/rng-tools.git \
12 file://init \
13 file://default \
14 file://rngd.service \
15 file://0001-Adding-ability-to-detect-non-posix-extensions-for-pt.patch \
16 file://0002-Allow-for-use-of-either-pthread-affinity-set-methods.patch \
17 "
18SRCREV = "c16176d3800b91f4d016b66733b384493b06f294"
Andrew Geissler82c905d2020-04-13 13:39:40 -050019
20S = "${WORKDIR}/git"
21
22inherit autotools update-rc.d systemd pkgconfig
23
Andrew Geissler4ed12e12020-06-05 18:00:41 -050024EXTRA_OECONF = "--without-rtlsdr"
25
26PACKAGECONFIG ??= "libjitterentropy"
Patrick Williams213cb262021-08-07 19:21:33 -050027PACKAGECONFIG:libc-musl = "libargp libjitterentropy"
Andrew Geissler82c905d2020-04-13 13:39:40 -050028
29PACKAGECONFIG[libargp] = "--with-libargp,--without-libargp,argp-standalone,"
Andrew Geissler82c905d2020-04-13 13:39:40 -050030PACKAGECONFIG[libjitterentropy] = "--enable-jitterentropy,--disable-jitterentropy,libjitterentropy"
31PACKAGECONFIG[libp11] = "--with-pkcs11,--without-pkcs11,libp11 openssl"
32PACKAGECONFIG[nistbeacon] = "--with-nistbeacon,--without-nistbeacon,curl libxml2 openssl"
33
34INITSCRIPT_NAME = "rng-tools"
35INITSCRIPT_PARAMS = "start 03 2 3 4 5 . stop 30 0 6 1 ."
36
Patrick Williams213cb262021-08-07 19:21:33 -050037SYSTEMD_SERVICE:${PN} = "rngd.service"
Andrew Geissler82c905d2020-04-13 13:39:40 -050038
39# Refer autogen.sh in rng-tools
Patrick Williams213cb262021-08-07 19:21:33 -050040do_configure:prepend() {
Andrew Geissler82c905d2020-04-13 13:39:40 -050041 cp ${S}/README.md ${S}/README
42}
43
Patrick Williams213cb262021-08-07 19:21:33 -050044do_install:append() {
Andrew Geissler82c905d2020-04-13 13:39:40 -050045 install -Dm 0644 ${WORKDIR}/default ${D}${sysconfdir}/default/rng-tools
46 install -Dm 0755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/rng-tools
47 install -Dm 0644 ${WORKDIR}/rngd.service \
48 ${D}${systemd_system_unitdir}/rngd.service
49 sed -i \
50 -e 's,@SYSCONFDIR@,${sysconfdir},g' \
51 -e 's,@SBINDIR@,${sbindir},g' \
52 ${D}${sysconfdir}/init.d/rng-tools \
53 ${D}${systemd_system_unitdir}/rngd.service
54
55 if [ "${@bb.utils.contains('PACKAGECONFIG', 'nistbeacon', 'yes', 'no', d)}" = "yes" ]; then
56 sed -i \
57 -e '/^IPAddressDeny=any/d' \
58 -e '/^RestrictAddressFamilies=/ s/$/ AF_INET AF_INET6/' \
59 ${D}${systemd_system_unitdir}/rngd.service
60 fi
61}