blob: 4f80a2bdb10b2d32ac949180b4b4d9dd20f98590 [file] [log] [blame]
Brad Bishopc342db32019-05-15 21:57:59 -04001SUMMARY = "Program for creating simple man pages"
2SECTION = "devel"
3LICENSE = "GPLv3"
Andrew Geissler4ed12e12020-06-05 18:00:41 -05004LIC_FILES_CHKSUM = "file://COPYING;md5=1ebbd3e34237af26da5dc08a4e440464"
Brad Bishopc342db32019-05-15 21:57:59 -04005DEPENDS = "autoconf-native automake-native"
6
7SRC_URI = "${GNU_MIRROR}/${BPN}/${BPN}-${PV}.tar.xz"
Andrew Geissler4ed12e12020-06-05 18:00:41 -05008SRC_URI[sha256sum] = "c25a35b30eceb315361484b0ff1f81c924e8ee5c8881576f1ee762f001dbcd1c"
Brad Bishopc342db32019-05-15 21:57:59 -04009
10inherit autotools native
11
12EXTRA_OECONF = "--disable-nls"
13
14# We don't want to reconfigure things as it would require 'perlnative' to be
15# used.
16do_configure() {
17 oe_runconf
18}
19
20do_install_append () {
21 # Make sure we use /usr/bin/env perl
22 sed -i -e "1s:#!.*:#! /usr/bin/env perl:" ${D}${bindir}/help2man
23}