blob: 09a6d16042a73452d360570ac73fc1e2bbc61d54 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001DESCRIPTION = "Small image capable of booting a device with custom install scripts, \
2adding a second rootfs, used for testing."
3
4# use -testfs live-install scripts
5PACKAGE_INSTALL = "initramfs-live-boot initramfs-live-install-testfs initramfs-live-install-efi-testfs busybox udev base-passwd ${ROOTFS_BOOTSTRAP_INSTALL}"
6
7# Do not pollute the initrd image with rootfs features
8IMAGE_FEATURES = ""
9
10export IMAGE_BASENAME = "core-image-testmaster-initramfs"
11IMAGE_LINGUAS = ""
12
13LICENSE = "MIT"
14
15IMAGE_FSTYPES = "${INITRAMFS_FSTYPES}"
16inherit core-image
17
18IMAGE_ROOTFS_SIZE = "8192"
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050019IMAGE_ROOTFS_EXTRA_SPACE = "0"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050020BAD_RECOMMENDATIONS += "busybox-syslog"
Patrick Williamsc0f7c042017-02-23 20:41:17 -060021
22# Use the same restriction as initramfs-live-install-testfs
23COMPATIBLE_HOST = "(i.86|x86_64).*-linux"