Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "Universal encoding detector for Python 2 and 3" |
| 2 | LICENSE = "LGPL-2.1" |
| 3 | LIC_FILES_CHKSUM = "file://LICENSE;md5=a6f89e2100d9b6cdffcea4f398e37343" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 4 | |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 5 | SRC_URI[md5sum] = "7dd1ba7f9c77e32351b0a0cfacf4055c" |
| 6 | SRC_URI[sha256sum] = "84ab92ed1c4d4f16916e05906b6b75a6c0fb5db821cc65e70cbd64a3e2a5eaae" |
| 7 | |
| 8 | # setup.py of chardet needs this. |
| 9 | DEPENDS += "${PYTHON_PN}-pytest-runner-native" |
| 10 | |
| 11 | inherit pypi setuptools3 |
| 12 | |
| 13 | PACKAGES =+ "${PN}-cli" |
| 14 | FILES_${PN}-cli += " \ |
| 15 | ${PYTHON_SITEPACKAGES_DIR}/chardet/cli \ |
| 16 | " |
| 17 | |
| 18 | RDEPENDS_${PN}-cli = "${PN} " |
| 19 | |
| 20 | RDEPENDS_${PN}_class-target += " \ |
| 21 | ${PYTHON_PN}-logging \ |
| 22 | " |
| 23 | |
| 24 | BBCLASSEXTEND = "native nativesdk" |