Andrew Geissler | d221e03 | 2020-07-10 16:13:21 -0500 | [diff] [blame] | 1 | SUMMARY = "Provides both a high- and low-level interface to the HDF5 library from Python." |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 2 | HOMEPAGE = "https://www.h5py.org/" |
| 3 | SECTION = "devel/python" |
Brad Bishop | 2d39a06 | 2019-10-28 08:33:36 -0400 | [diff] [blame] | 4 | LICENSE = "BSD-3-Clause" |
Andrew Geissler | d221e03 | 2020-07-10 16:13:21 -0500 | [diff] [blame] | 5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=113251d71fb0384712c719b567261c5c" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 6 | |
Andrew Geissler | d221e03 | 2020-07-10 16:13:21 -0500 | [diff] [blame] | 7 | SRC_URI[md5sum] = "504b595237409ab766fbbe568e60a080" |
| 8 | SRC_URI[sha256sum] = "84412798925dc870ffd7107f045d7659e60f5d46d1c70c700375248bf6bf512d" |
| 9 | |
| 10 | SRC_URI_append = " \ |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 11 | file://0001-cross-compiling-support.patch \ |
| 12 | " |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 13 | |
Andrew Geissler | d221e03 | 2020-07-10 16:13:21 -0500 | [diff] [blame] | 14 | inherit pypi setuptools3 |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 15 | |
| 16 | BBCLASSEXTEND = "native" |
| 17 | |
| 18 | DEPENDS = "python3-pkgconfig-native \ |
| 19 | python3-cython-native \ |
| 20 | python3-numpy-native \ |
| 21 | python3-six-native \ |
| 22 | python3 \ |
| 23 | hdf5 \ |
| 24 | " |
| 25 | |
| 26 | RDEPENDS_${PN} = "python3-numpy \ |
| 27 | python3-six \ |
| 28 | " |
| 29 | |
Andrew Geissler | d221e03 | 2020-07-10 16:13:21 -0500 | [diff] [blame] | 30 | export HDF5_VERSION="1.8.21" |