blob: 4c857c3fd0a0c9eee0ac40e9b8c47a1bd6322e40 [file] [log] [blame]
Brad Bishop316dfdd2018-06-25 12:45:53 -04001LICENSE = "LGPLv2.1 & GPLv2"
2LIC_FILES_CHKSUM = "file://LICENSE.LGPL2.1;md5=4fbd65380cdd255951079008b364516c \
3 file://LICENSE.GPL2;md5=751419260aa954499f7abaabaa882bbe"
4
5SRC_URI = "git://github.com/systemd/systemd-bootchart.git;protocol=https \
Andrew Geissler82c905d2020-04-13 13:39:40 -05006 file://0001-architecture-Recognise-RISCV-32-RISCV-64.patch \
7 file://mips64.patch \
Brad Bishop316dfdd2018-06-25 12:45:53 -04008"
9
10SRC_URI_append_libc-musl = " \
11 file://0001-comparison_fn_t-is-glibc-specific-use-raw-signature-.patch \
12 file://0002-musl-does-not-provide-printf-h.patch \
13 file://0003-musl-does-not-provide-canonicalize_file_name.patch \
14 "
15
16
Andrew Geisslerd1e89492021-02-12 15:35:20 -060017SRCREV = "8183cfd9dad8beca5434d625cf6b2df87775e956"
Brad Bishop316dfdd2018-06-25 12:45:53 -040018
19S = "${WORKDIR}/git"
20
21DEPENDS = "systemd libxslt-native xmlto-native docbook-xml-dtd4-native docbook-xsl-stylesheets-native intltool"
22
Brad Bishop6dbb3162019-11-25 09:41:34 -050023inherit pkgconfig autotools systemd features_check
Brad Bishop316dfdd2018-06-25 12:45:53 -040024
25REQUIRED_DISTRO_FEATURES = "systemd"
26
27SYSTEMD_SERVICE_${PN} = "systemd-bootchart.service"
28
29do_configure_prepend() {
30 # intltool.m4 is a soft link to /usr/share/aclocal/m4, delete it and use the one in our sysroot
31 rm -f ${S}/m4/intltool.m4
32}
33
34FILES_${PN} += "${systemd_unitdir}/systemd-bootchart"
35
Brad Bishop79641f22019-09-10 07:20:22 -040036EXTRA_OECONF = " --with-rootprefix=${root_prefix} \
Brad Bishop316dfdd2018-06-25 12:45:53 -040037 --with-rootlibdir=${base_libdir}"