blob: 5e34cdf9e5673cff9a9689f7f5f798977ceefaee [file] [log] [blame]
Brad Bishopc342db32019-05-15 21:57:59 -04001SUMMARY = "GNU file archiving program"
2DESCRIPTION = "GNU tar saves many files together into a single tape \
3or disk archive, and can restore individual files from the archive."
4HOMEPAGE = "http://www.gnu.org/software/tar/"
5SECTION = "base"
6LICENSE = "GPLv3"
7LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
8
Andrew Geisslerd1e89492021-02-12 15:35:20 -06009SRC_URI = "${GNU_MIRROR}/tar/tar-${PV}.tar.bz2"
Brad Bishopc342db32019-05-15 21:57:59 -040010
Andrew Geisslerd1e89492021-02-12 15:35:20 -060011SRC_URI[sha256sum] = "85b6953f4bc9666eb7db61b48f150dca21b941d85090171ea8c4f89902e460af"
Brad Bishopc342db32019-05-15 21:57:59 -040012
13inherit autotools gettext texinfo
14
15PACKAGECONFIG ??= ""
16PACKAGECONFIG_append_class-target = " ${@bb.utils.filter('DISTRO_FEATURES', 'acl', d)}"
17
18PACKAGECONFIG[acl] = "--with-posix-acls,--without-posix-acls,acl"
19
20EXTRA_OECONF += "DEFAULT_RMT_DIR=${sbindir}"
21
Andrew Geissler82c905d2020-04-13 13:39:40 -050022CACHED_CONFIGUREVARS += "tar_cv_path_RSH=no"
23
Brad Bishopc342db32019-05-15 21:57:59 -040024# Let aclocal use the relative path for the m4 file rather than the
25# absolute since tar has a lot of m4 files, otherwise there might
26# be an "Argument list too long" error when it is built in a long/deep
27# directory.
28acpaths = "-I ./m4"
29
30do_install () {
31 autotools_do_install
32 ln -s tar ${D}${bindir}/gtar
33}
34
35do_install_append_class-target() {
36 if [ "${base_bindir}" != "${bindir}" ]; then
37 install -d ${D}${base_bindir}
38 mv ${D}${bindir}/tar ${D}${base_bindir}/tar
39 mv ${D}${bindir}/gtar ${D}${base_bindir}/gtar
40 rmdir ${D}${bindir}/
41 fi
42}
43
44PACKAGES =+ "${PN}-rmt"
45
46FILES_${PN}-rmt = "${sbindir}/rmt*"
47
48inherit update-alternatives
49
50ALTERNATIVE_PRIORITY = "100"
51
52ALTERNATIVE_${PN} = "tar"
53ALTERNATIVE_${PN}-rmt = "rmt"
54ALTERNATIVE_${PN}_class-nativesdk = ""
55ALTERNATIVE_${PN}-rmt_class-nativesdk = ""
56
57ALTERNATIVE_LINK_NAME[tar] = "${base_bindir}/tar"
58ALTERNATIVE_LINK_NAME[rmt] = "${sbindir}/rmt"
59
60PROVIDES_append_class-native = " tar-replacement-native"
61NATIVE_PACKAGE_PATH_SUFFIX = "/${PN}"
62
63BBCLASSEXTEND = "native nativesdk"