blob: 8125399418a47a6c652062dcbce7f82ae29f2ed8 [file] [log] [blame]
Andrew Geissler2ee498a2020-05-29 15:52:06 -05001DESCRIPTION = "An implementation of RFC 7049 - Concise Binary Object Representation (CBOR)."
2DEPENDS +="${PYTHON_PN}-setuptools-scm-native"
3
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
6
7SRC_URI[sha256sum] = "43ce11e8c2fe4971d386d1a60cf83bfa0a4a667b97668ba76acbf5e6398821aa"
8
Andrew Geisslerd221e032020-07-10 16:13:21 -05009inherit pypi setuptools3 ptest
10
11SRC_URI += " \
12 file://run-ptest \
13"
14
15RDEPENDS_${PN}-ptest += " \
16 ${PYTHON_PN}-pytest \
17 ${PYTHON_PN}-unixadmin \
18"
19
20do_install_ptest() {
21 install -d ${D}${PTEST_PATH}/tests
22 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
23}
Andrew Geissler2ee498a2020-05-29 15:52:06 -050024
25RDEPENDS_${PN} += " \
26 ${PYTHON_PN}-datetime \
27"
28
29BBCLASSEXTEND = "native nativesdk"