Andrew Geissler | 32b1199 | 2021-03-31 13:37:05 -0500 | [diff] [blame] | 1 | # Copyright (C) 2021 Khem Raj <raj.khem@gmail.com> |
| 2 | # Released under the MIT license (see COPYING.MIT for the terms) |
| 3 | |
| 4 | SUMMARY = "A C library that may be linked into a C/C++ program to produce symbolic backtraces" |
| 5 | HOMEPAGE = "https://github.com/ianlancetaylor/libbacktrace" |
| 6 | LICENSE = "BSD-3-Clause" |
| 7 | LIC_FILES_CHKSUM = "file://LICENSE;md5=24b5b3feec63c4be0975e1fea5100440" |
| 8 | |
| 9 | DEPENDS += "libunwind" |
| 10 | |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 11 | SRC_URI = "git://github.com/ianlancetaylor/libbacktrace;protocol=https;branch=master" |
Andrew Geissler | 32b1199 | 2021-03-31 13:37:05 -0500 | [diff] [blame] | 12 | |
| 13 | PV = "1.0+git${SRCPV}" |
| 14 | SRCREV = "4f57c999716847e45505b3df170150876b545088" |
| 15 | |
| 16 | S = "${WORKDIR}/git" |
| 17 | |
| 18 | inherit autotools |
| 19 | |
| 20 | EXTR_OECONF += "--with-system-libunwind" |
| 21 | |
| 22 | CFLAGS += "-fPIC" |
| 23 | |
| 24 | do_configure() { |
| 25 | oe_runconf |
| 26 | } |
| 27 | |
| 28 | # libunwind does not support RISCV yet |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 29 | COMPATIBLE_HOST:riscv64 = "null" |
| 30 | COMPATIBLE_HOST:riscv32 = "null" |