Andrew Geissler | 1fe918a | 2020-05-15 14:16:47 -0500 | [diff] [blame] | 1 | SUMMARY = "Checksec tool" |
| 2 | DESCRIPTION = "The checksec.sh script is designed to test what standard Linux OS and PaX security features are being used." |
| 3 | SECTION = "security" |
| 4 | LICENSE = "BSD-3-Clause" |
| 5 | HOMEPAGE="http://www.trapkit.de/tools/checksec.html" |
| 6 | |
| 7 | LIC_FILES_CHKSUM = "file://checksec-${PV}.sh;beginline=3;endline=34;md5=6dab14470bfdf12634b866dbdd7a04b0" |
| 8 | |
| 9 | SRC_URI = "http://www.trapkit.de/tools/checksec.sh;downloadfilename=checksec-${PV}.sh" |
| 10 | |
| 11 | SRC_URI[md5sum] = "57cc3fbbbe48e8ebd4672c569954374d" |
| 12 | SRC_URI[sha256sum] = "05822cd8668589038d20650faa0e56f740911d8ad06f7005b3d12a5c76591b90" |
| 13 | |
| 14 | |
| 15 | S = "${WORKDIR}" |
| 16 | |
| 17 | do_install() { |
| 18 | install -d ${D}${bindir} |
| 19 | install -m 0755 ${WORKDIR}/checksec-${PV}.sh ${D}${bindir}/checksec.sh |
| 20 | sed -i 's/\r//' ${D}${bindir}/checksec.sh |
| 21 | } |
| 22 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 23 | RDEPENDS:${PN} = "bash binutils" |
Andrew Geissler | 1fe918a | 2020-05-15 14:16:47 -0500 | [diff] [blame] | 24 | |
| 25 | BBCLASSEXTEND = "native" |