blob: 035270e484066367a268b72e4409c5563c71b4a3 [file] [log] [blame]
Brad Bishop3077a7f2017-01-12 21:44:51 -05001SUMMARY = "OpenBMC - Applications"
Brad Bishop93fb5352015-09-09 03:59:20 +00002PR = "r1"
3
4inherit packagegroup
5inherit obmc-phosphor-utils
6inherit obmc-phosphor-license
7
Brad Bishop93fb5352015-09-09 03:59:20 +00008PROVIDES = "${PACKAGES}"
9PACKAGES = " \
Brad Bishopdb32a7c2017-03-01 16:16:06 -050010 ${PN}-bmc-state-mgmt \
11 ${PN}-chassis-state-mgmt \
Brad Bishopa2429372016-09-06 22:44:21 -040012 ${PN}-extras \
13 ${PN}-extrasdev \
Brad Bishop4824d4c2017-05-01 11:54:34 -040014 ${PN}-fan-control \
Brad Bishopdb32a7c2017-03-01 16:16:06 -050015 ${PN}-host-state-mgmt \
Brad Bishop4f12f722017-02-01 21:04:14 -050016 ${PN}-inventory \
17 ${PN}-leds \
18 ${PN}-sensors \
Gunnar Mills058788a2017-02-15 16:01:45 -060019 ${PN}-software \
Andrew Geisslerb1afecc2017-05-08 15:58:01 -050020 ${PN}-host-check-mgmt \
Jayanth Othayoth9be81b12017-05-08 09:25:05 -050021 ${PN}-debug-collector \
Deepak Kodihallifeb88672017-05-17 06:42:51 -050022 ${PN}-settings \
Ratan Guptad3c61642017-07-06 21:09:14 +053023 ${PN}-network \
Brad Bishop93fb5352015-09-09 03:59:20 +000024 "
25
Brad Bishopdb32a7c2017-03-01 16:16:06 -050026SUMMARY_${PN}-bmc-state-mgmt = "BMC state management"
27RDEPENDS_${PN}-bmc-state-mgmt = " \
28 ${VIRTUAL-RUNTIME_obmc-bmc-state-manager} \
29 "
30
31SUMMARY_${PN}-chassis-state-mgmt = "Chassis state management"
32RDEPENDS_${PN}-chassis-state-mgmt = " \
33 ${VIRTUAL-RUNTIME_obmc-chassis-state-manager} \
34 "
35
Andrew Geisslerb1afecc2017-05-08 15:58:01 -050036SUMMARY_${PN}-host-check-mgmt = "Host state check on bmc reset"
37RDEPENDS_${PN}-host-check-mgmt = " \
38 ${VIRTUAL-RUNTIME_obmc-host-check} \
39 "
40
Brad Bishopa2429372016-09-06 22:44:21 -040041SUMMARY_${PN}-extras = "Extra features"
42RDEPENDS_${PN}-extras = " \
Brad Bishop3077a7f2017-01-12 21:44:51 -050043 phosphor-rest \
Brad Bishop0f547b12017-05-31 14:08:33 -040044 phosphor-dbus-monitor \
Brad Bishop70436da2015-09-16 14:49:27 -040045 "
46
Brad Bishopa2429372016-09-06 22:44:21 -040047SUMMARY_${PN}-extrasdev = "Development features"
48RDEPENDS_${PN}-extrasdev = " \
Adriana Kobylaka3e925f2016-06-16 14:46:06 -050049 rest-dbus \
50 "
Brad Bishop4f12f722017-02-01 21:04:14 -050051
Brad Bishop4824d4c2017-05-01 11:54:34 -040052# Use the fan control package group for applications
53# implementing fan control or system fan policy only.
54# Applications that create inventory or sensors should
55# be added those respective package groups instead.
56SUMMARY_${PN}-fan-control = "Fan control"
57RDEPENDS_${PN}-fan-control = " \
Matt Spinlerc133ec12017-04-19 08:23:50 -050058 ${VIRTUAL-RUNTIME_obmc-fan-control} \
Matt Spinlerdd7a0802017-05-01 14:29:20 -050059 phosphor-fan-monitor \
Brad Bishop4824d4c2017-05-01 11:54:34 -040060 "
61
Brad Bishopdb32a7c2017-03-01 16:16:06 -050062SUMMARY_${PN}-host-state-mgmt = "Host state management"
63RDEPENDS_${PN}-host-state-mgmt = " \
64 ${VIRTUAL-RUNTIME_obmc-host-state-manager} \
Michael Tritzb3b58992017-03-31 12:04:32 -050065 ${VIRTUAL-RUNTIME_obmc-discover-system-state} \
Brad Bishopdb32a7c2017-03-01 16:16:06 -050066 "
67
Brad Bishop4f12f722017-02-01 21:04:14 -050068SUMMARY_${PN}-inventory = "Inventory applications"
69RDEPENDS_${PN}-inventory = " \
70 ${VIRTUAL-RUNTIME_obmc-inventory-manager} \
Matthew Barthacd9fe42017-02-24 13:14:43 -060071 ${VIRTUAL-RUNTIME_obmc-fan-presence} \
Brad Bishop4f12f722017-02-01 21:04:14 -050072 "
73
74SUMMARY_${PN}-leds = "LED applications"
75RDEPENDS_${PN}-leds = " \
Brad Bishopaf7d0602017-02-27 11:59:49 -050076 ${VIRTUAL-RUNTIME_obmc-leds-manager} \
77 ${VIRTUAL-RUNTIME_obmc-leds-sysfs} \
Dhruvaraj Subhashchandran6a1b0fc2017-04-27 05:29:56 -050078 ${VIRTUAL-RUNTIME_obmc-led-monitor} \
Brad Bishop4f12f722017-02-01 21:04:14 -050079 "
80
81SUMMARY_${PN}-sensors = "Sensor applications"
82RDEPENDS_${PN}-sensors = " \
83 ${VIRTUAL-RUNTIME_obmc-sensors-hwmon} \
84 "
Gunnar Mills058788a2017-02-15 16:01:45 -060085
86SUMMARY_${PN}-software = "Software applications"
87RDEPENDS_${PN}-software = " \
88 ${VIRTUAL-RUNTIME_obmc-bmc-code-mgr} \
Deepak Kodihallib74ceea2017-04-13 23:23:42 -050089 ${VIRTUAL-RUNTIME_obmc-bmc-download-mgr} \
Gunnar Millscfe00842017-05-15 15:40:58 -050090 ${VIRTUAL-RUNTIME_obmc-bmc-updater} \
Gunnar Mills058788a2017-02-15 16:01:45 -060091 "
Jayanth Othayoth9be81b12017-05-08 09:25:05 -050092SUMMARY_${PN}-debug-collector = "BMC debug collector"
93RDEPENDS_${PN}-debug-collector = " \
Jayanth Othayoth2a5d91e2017-05-31 06:25:55 -050094 ${VIRTUAL-RUNTIME_obmc-dump-manager} \
95 ${VIRTUAL-RUNTIME_obmc-dump-monitor} \
Vishwanatha Subbannadfd5bf32017-05-12 23:31:55 +053096 "
Deepak Kodihallifeb88672017-05-17 06:42:51 -050097
98SUMMARY_${PN}-settings = "Settings applications"
99RDEPENDS_${PN}-settings = " \
100 ${VIRTUAL-RUNTIME_obmc-settings-mgr} \
101 "
Ratan Guptad3c61642017-07-06 21:09:14 +0530102
103SUMMARY_${PN}-network = "BMC Network Manager"
104RDEPENDS_${PN}-network = " \
105 ${VIRTUAL-RUNTIME_obmc-network-manager} \
106 "