Andrew Geissler | d25ed32 | 2020-06-27 00:28:28 -0500 | [diff] [blame] | 1 | SUMMARY = "IGT GPU Tools" |
| 2 | DESCRIPTION = "IGT GPU Tools is a collection of tools for development and testing of the DRM drivers" |
| 3 | |
| 4 | LIC_FILES_CHKSUM = "file://COPYING;md5=67bfee4df38fa6ecbe3a675c552d4c08" |
| 5 | |
| 6 | LICENSE = "MIT" |
| 7 | |
| 8 | inherit meson |
| 9 | |
| 10 | SRCREV = "d16ad07e7f2a028e14d61f570931c87fa5ce404c" |
| 11 | PV = "1.25+git${SRCPV}" |
| 12 | |
| 13 | SRC_URI = "git://gitlab.freedesktop.org/drm/igt-gpu-tools.git;protocol=https" |
| 14 | |
| 15 | S = "${WORKDIR}/git" |
| 16 | |
| 17 | DEPENDS += "libdrm libpciaccess cairo udev glib-2.0 procps libunwind kmod openssl elfutils alsa-lib json-c bison-native" |
| 18 | RDEPENDS_${PN} += "bash" |
| 19 | RDEPENDS_${PN}-tests += "bash" |
| 20 | |
| 21 | PACKAGE_BEFORE_PN = "${PN}-benchmarks ${PN}-tests" |
| 22 | |
Andrew Geissler | b7d2861 | 2020-07-24 16:15:54 -0500 | [diff] [blame] | 23 | PACKAGECONFIG[chamelium] = "-Dchamelium=enabled,-Dchamelium=disabled,gsl xmlrpc-c" |
| 24 | |
Andrew Geissler | d25ed32 | 2020-06-27 00:28:28 -0500 | [diff] [blame] | 25 | EXTRA_OEMESON = "-Ddocs=disabled -Drunner=enabled" |
| 26 | COMPATIBLE_HOST = "(x86_64.*|i.86.*|arm.*|aarch64).*-linux" |
| 27 | COMPATIBLE_HOST_libc-musl_class-target = "null" |
| 28 | SECURITY_LDFLAGS = "${SECURITY_X_LDFLAGS}" |
| 29 | |
| 30 | gputools_sysroot_preprocess() { |
| 31 | rm -f ${SYSROOT_DESTDIR}${libdir}/pkgconfig/intel-gen4asm.pc |
| 32 | } |
| 33 | SYSROOT_PREPROCESS_FUNCS += "gputools_sysroot_preprocess" |
| 34 | |
| 35 | do_install_append() { |
| 36 | install -d ${D}/usr/share/${BPN}/scripts |
| 37 | install ${S}/scripts/run-tests.sh ${D}/usr/share/${BPN}/scripts |
| 38 | install -d ${D}/usr/share/${BPN}/runner |
| 39 | install -D ${B}/runner/igt_runner ${D}/usr/share/${BPN}/runner |
| 40 | install -D ${B}/runner/igt_resume ${D}/usr/share/${BPN}/runner |
| 41 | } |
| 42 | |
| 43 | FILES_${PN}-benchmarks += "${libexecdir}/${BPN}/benchmarks" |
| 44 | FILES_${PN}-tests += "\ |
| 45 | ${libexecdir}/${BPN}/*\ |
| 46 | ${datadir}/${BPN}/1080p-right.png\ |
| 47 | ${datadir}/${BPN}/1080p-left.png\ |
| 48 | ${datadir}/${BPN}/pass.png\ |
| 49 | ${datadir}/${BPN}/test-list.txt" |