blob: 118c1c2b0eb8dfeebc78f844b21f3b7dc2a0a15b [file] [log] [blame]
Brad Bishop7cce0f22017-01-17 09:21:15 -05001SUMMARY = "Phosphor IPMI plugin for OpenPOWER OEM Commands"
2DESCRIPTION = "Phosphor IPMI plugin for OpenPOWER OEM Commands"
Chris Austen9d3325a2015-10-24 19:34:11 -05003PR = "r1"
4
Matthew Barthe6d12952016-09-28 09:51:58 -05005inherit autotools pkgconfig
Chris Austen9d3325a2015-10-24 19:34:11 -05006inherit obmc-phosphor-license
Tom Josephdcdc8ea2017-02-01 19:47:27 +05307inherit obmc-phosphor-ipmiprovider-symlink
Tom Joseph464b90a2017-10-17 22:52:49 +05308inherit pythonnative
9
10require ${PN}.inc
Chris Austen9d3325a2015-10-24 19:34:11 -050011
Brad Bishopceb1c9a2017-01-17 10:07:14 -050012DEPENDS += "phosphor-ipmi-host"
Matthew Barthe6d12952016-09-28 09:51:58 -050013DEPENDS += "autoconf-archive-native"
Patrick Williams04f099a2017-08-17 10:42:32 -050014DEPENDS += "sdbusplus sdbusplus-native"
15DEPENDS += "phosphor-logging"
16DEPENDS += "phosphor-dbus-interfaces phosphor-dbus-interfaces-native"
17DEPENDS += "openpower-dbus-interfaces openpower-dbus-interfaces-native"
Tom Joseph464b90a2017-10-17 22:52:49 +053018DEPENDS += "sdbus++-native"
Patrick Williams04f099a2017-08-17 10:42:32 -050019
20RDEPENDS_${PN} += " \
21 sdbusplus \
22 phosphor-logging \
23 openpower-dbus-interfaces \
24 phosphor-dbus-interfaces \
25 "
Matthew Barthe6d12952016-09-28 09:51:58 -050026
Chris Austenf6d294d2016-01-23 18:00:11 -060027TARGET_CFLAGS += "-fpic"
Chris Austen9d3325a2015-10-24 19:34:11 -050028
Tom Josephdcdc8ea2017-02-01 19:47:27 +053029HOSTIPMI_PROVIDER_LIBRARY += "liboemhandler.so"
30
Chris Austen9d3325a2015-10-24 19:34:11 -050031S = "${WORKDIR}/git"
32
Tom Josephdcdc8ea2017-02-01 19:47:27 +053033FILES_${PN}_append = " ${libdir}/ipmid-providers/lib*${SOLIBS}"
Matthew Barthe6d12952016-09-28 09:51:58 -050034FILES_${PN}_append = " ${libdir}/host-ipmid/lib*${SOLIBS}"
Tom Josephdcdc8ea2017-02-01 19:47:27 +053035FILES_${PN}-dev_append = " ${libdir}/ipmid-providers/lib*${SOLIBSDEV} ${libdir}/ipmid-providers/*.la"