Patrick Williams | 975a06f | 2022-10-21 14:42:47 -0500 | [diff] [blame] | 1 | SUMMARY = "Double conversion libraries" |
| 2 | DESCRIPTION = "This provides binary-decimal and decimal-binary routines for IEEE doubles." |
| 3 | HOMEPAGE = "https://github.com/google/double-conversion.git" |
| 4 | |
| 5 | LICENSE = "BSD-3-Clause" |
| 6 | LIC_FILES_CHKSUM = "file://LICENSE;md5=1ea35644f0ec0d9767897115667e901f" |
| 7 | |
| 8 | |
| 9 | S = "${WORKDIR}/git" |
| 10 | |
| 11 | SRC_URI = " \ |
| 12 | git://github.com/google/double-conversion.git;protocol=https;branch=master \ |
Patrick Williams | 8e7b46e | 2023-05-01 14:19:06 -0500 | [diff] [blame] | 13 | file://run-ptest \ |
Patrick Williams | 975a06f | 2022-10-21 14:42:47 -0500 | [diff] [blame] | 14 | " |
Patrick Williams | e760df8 | 2023-05-26 11:10:49 -0500 | [diff] [blame] | 15 | SRCREV = "4f7a25d8ced8c7cf6eee6fd09d6788eaa23c9afe" |
Patrick Williams | 975a06f | 2022-10-21 14:42:47 -0500 | [diff] [blame] | 16 | |
Patrick Williams | 8e7b46e | 2023-05-01 14:19:06 -0500 | [diff] [blame] | 17 | inherit cmake ptest |
Patrick Williams | 975a06f | 2022-10-21 14:42:47 -0500 | [diff] [blame] | 18 | |
| 19 | EXTRA_OECMAKE = "-DBUILD_SHARED_LIBS=ON" |
Patrick Williams | 8e7b46e | 2023-05-01 14:19:06 -0500 | [diff] [blame] | 20 | |
| 21 | # These ptest use ctest (provided by cmake) |
| 22 | RDEPENDS:${PN}-ptest += "cmake" |
| 23 | # Build tests only if ptest is enabled |
| 24 | EXTRA_OECMAKE += "${@bb.utils.contains('PTEST_ENABLED', '1', '-DBUILD_TESTING=ON', '', d)}" |
| 25 | |
| 26 | do_install_ptest() { |
| 27 | install -d ${D}${PTEST_PATH}/test |
| 28 | cp -rf ${B}/test ${D}${PTEST_PATH} |
| 29 | install -m 0644 ${B}/CTestTestfile.cmake ${D}${PTEST_PATH}/ |
| 30 | files=" |
| 31 | CTestTestfile.cmake |
| 32 | test/CTestTestfile.cmake |
| 33 | test/cmake_install.cmake |
| 34 | test/cctest/CTestTestfile.cmake |
| 35 | test/cctest/cmake_install.cmake |
| 36 | " |
| 37 | for file in $files; do |
| 38 | sed -i -e "s|${B}|${PTEST_PATH}|g" -e "s|${S}|${PTEST_PATH}|g" -e "s|${WORKDIR}/recipe-sysroot-native||g" "${D}${PTEST_PATH}/${file}" |
| 39 | done |
| 40 | |
| 41 | } |