blob: 831b15a455da70307f15ca6f2b6f948002e837db [file] [log] [blame]
Brad Bishop665fd022019-08-26 01:32:28 -04001SUMMARY = "Enumerate all known properties of OpenCL platform and devices."
2DESCRIPTION = "clinfo is a simple command-line application that enumerates \
3all possible (known) properties of the OpenCL platform and devices \
4available on the system."
5HOMEPAGE = "https://github.com/Oblomov/clinfo"
6
7LICENSE = "CC0-1.0"
8LIC_FILES_CHKSUM = "file://LICENSE;md5=fd8857f774dfb0eefe1e80c8f9240a7e"
9
Andrew Geissler595f6302022-01-24 19:11:47 +000010SRC_URI = "git://github.com/Oblomov/clinfo.git;protocol=https;branch=master"
Brad Bishop665fd022019-08-26 01:32:28 -040011
12SRCREV = "59d0daf898e48d76ccbb788acbba258fa0a8ba7c"
13
14S = "${WORKDIR}/git"
15
16DEPENDS += "opencl-headers opencl-icd-loader"
17
18do_install() {
19 install -D -m 755 clinfo ${D}${bindir}/clinfo
20}