blob: 7d72a5198bff6fa49576d79894879409074806ea [file] [log] [blame]
Andrew Geissler9aee5002022-03-30 16:27:02 +00001SUMMARY = "Bash Automated Testing System"
2DESCRIPTION = "Bats is a TAP-compliant testing framework for Bash. It \
3provides a simple way to verify that the UNIX programs you write behave as expected."
4AUTHOR = "Sam Stephenson & bats-core organization"
5HOMEPAGE = "https://github.com/bats-core/bats-core"
6LICENSE = "MIT"
7LIC_FILES_CHKSUM = "file://LICENSE.md;md5=2970203aedf9e829edb96a137a4fe81b"
8
Andrew Geisslerd5838332022-05-27 11:33:10 -05009SRC_URI = "\
10 git://github.com/bats-core/bats-core.git;branch=version/1.6.x;protocol=https \
11 "
12
13# v1.6.1
14SRCREV = "1977254c2a7faa2e0af17355856f91dc471d1daa"
Andrew Geissler9aee5002022-03-30 16:27:02 +000015
16S = "${WORKDIR}/git"
17
18do_configure:prepend() {
19 sed -i 's:\$BATS_ROOT/lib:\$BATS_ROOT/${baselib}:g' ${S}/libexec/bats-core/bats
20 sed -i 's:\$BATS_ROOT/lib:\$BATS_ROOT/${baselib}:g' ${S}/libexec/bats-core/bats-exec-file
21 sed -i 's:\$BATS_ROOT/lib:\$BATS_ROOT/${baselib}:g' ${S}/libexec/bats-core/bats-exec-test
22}
23
24do_install() {
25 # Just a bunch of bash scripts to install
26 ${S}/install.sh ${D}${prefix} ${baselib}
27}
28
29RDEPENDS:${PN} = "bash"
30FILES:${PN} += "${libdir}/bats-core/*"
31
32PACKAGECONFIG ??= "pretty"
33PACKAGECONFIG[pretty] = ",,,ncurses"