blob: 92532237e032a90f87cf8be23ca41b14912c3463 [file] [log] [blame]
Patrick Williams03907ee2022-05-01 06:28:52 -05001# Copyright (C) 2022 Khem Raj <raj.khem@gmail.com>
2# Released under the MIT license (see COPYING.MIT for the terms)
3#
4SUMMARY = "Locales support for musl"
Andrew Geisslerd5838332022-05-27 11:33:10 -05005HOMEPAGE = "https://git.adelielinux.org/adelie/musl-locales/-/wikis/home"
Patrick Williams03907ee2022-05-01 06:28:52 -05006LICENSE = "MIT & LGPL-3.0-or-later"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=cf5713fba707073020b1db2acaa73e78 \
8 file://LICENSE.MIT;md5=a4f1c6864a83ddf4b754cdab7d593523"
9
Andrew Geisslerd5838332022-05-27 11:33:10 -050010SRC_URI = "git://git.adelielinux.org/adelie/musl-locales;protocol=https;branch=main"
Patrick Williams03907ee2022-05-01 06:28:52 -050011
12PV = "1.0+git${SRCPV}"
Andrew Geisslerd5838332022-05-27 11:33:10 -050013SRCREV = "cac3dcdccd1d0c08d17f4919d862737d64b76f79"
Patrick Williams03907ee2022-05-01 06:28:52 -050014
15S = "${WORKDIR}/git"
16
17DEPENDS = "virtual/libintl gettext-native"
18
19PROVIDES = "virtual/libc-locale"
20
21inherit cmake
22
23# We will skip parsing for non-musl systems
24python () {
25 if d.getVar('TCLIBC') != "musl":
26 raise bb.parse.SkipRecipe("Only use it with Musl C library")
27}
28
29# only locale binaries are under GPL-3.0-or-later others are MIT
30LICENSE:${PN} = "LGPL-3.0-or-later"
Andrew Geisslerd5838332022-05-27 11:33:10 -050031LICENSE:locale-base-cs-cz = "MIT"
Patrick Williams03907ee2022-05-01 06:28:52 -050032LICENSE:locale-base-de-ch = "MIT"
33LICENSE:locale-base-de-de = "MIT"
34LICENSE:locale-base-en-gb = "MIT"
35LICENSE:locale-base-en-us = "MIT"
36LICENSE:locale-base-es-es = "MIT"
Andrew Geisslerd5838332022-05-27 11:33:10 -050037LICENSE:locale-base-fi-fi = "MIT"
Patrick Williams03907ee2022-05-01 06:28:52 -050038LICENSE:locale-base-fr-fr = "MIT"
39LICENSE:locale-base-it-it = "MIT"
40LICENSE:locale-base-nb-no = "MIT"
41LICENSE:locale-base-nl-nl = "MIT"
42LICENSE:locale-base-pt-br = "MIT"
Andrew Geisslerd5838332022-05-27 11:33:10 -050043LICENSE:locale-base-pt-pt = "MIT"
Patrick Williams03907ee2022-05-01 06:28:52 -050044LICENSE:locale-base-ru-ru = "MIT"
Andrew Geisslerd5838332022-05-27 11:33:10 -050045LICENSE:locale-base-sr-rs = "MIT"
Patrick Williams03907ee2022-05-01 06:28:52 -050046LICENSE:locale-base-sv-se = "MIT"
47
Andrew Geisslerd5838332022-05-27 11:33:10 -050048PACKAGES =+ "locale-base-cs-cz \
Patrick Williams03907ee2022-05-01 06:28:52 -050049 locale-base-de-ch \
50 locale-base-de-de \
51 locale-base-en-gb \
52 locale-base-en-us \
53 locale-base-es-es \
Andrew Geisslerd5838332022-05-27 11:33:10 -050054 locale-base-fi-fi \
Patrick Williams03907ee2022-05-01 06:28:52 -050055 locale-base-fr-fr \
56 locale-base-it-it \
57 locale-base-nb-no \
58 locale-base-nl-nl \
59 locale-base-pt-br \
Andrew Geisslerd5838332022-05-27 11:33:10 -050060 locale-base-pt-pt \
Patrick Williams03907ee2022-05-01 06:28:52 -050061 locale-base-ru-ru \
Andrew Geisslerd5838332022-05-27 11:33:10 -050062 locale-base-sr-rs \
Patrick Williams03907ee2022-05-01 06:28:52 -050063 locale-base-sv-se \
64 "
Andrew Geisslerd5838332022-05-27 11:33:10 -050065FILES:locale-base-cs-cz += "${datadir}/i18n/locales/musl/cs_CZ.UTF-8"
Patrick Williams03907ee2022-05-01 06:28:52 -050066FILES:locale-base-de-ch += "${datadir}/i18n/locales/musl/de_CH.UTF-8"
67FILES:locale-base-de-de += "${datadir}/i18n/locales/musl/de_DE.UTF-8"
68FILES:locale-base-en-gb += "${datadir}/i18n/locales/musl/en_GB.UTF-8"
69FILES:locale-base-en-us += "${datadir}/i18n/locales/musl/en_US.UTF-8"
70FILES:locale-base-es-es += "${datadir}/i18n/locales/musl/es_ES.UTF-8"
Andrew Geisslerd5838332022-05-27 11:33:10 -050071FILES:locale-base-fi-fi += "${datadir}/i18n/locales/musl/fi_FI.UTF-8"
Patrick Williams03907ee2022-05-01 06:28:52 -050072FILES:locale-base-fr-fr += "${datadir}/i18n/locales/musl/fr_FR.UTF-8"
73FILES:locale-base-it-it += "${datadir}/i18n/locales/musl/it_IT.UTF-8"
74FILES:locale-base-nb-no += "${datadir}/i18n/locales/musl/nb_NO.UTF-8"
75FILES:locale-base-nl-nl += "${datadir}/i18n/locales/musl/nl_NL.UTF-8"
76FILES:locale-base-pt-br += "${datadir}/i18n/locales/musl/pt_BR.UTF-8"
Andrew Geisslerd5838332022-05-27 11:33:10 -050077FILES:locale-base-pt-pt += "${datadir}/i18n/locales/musl/pt_PT.UTF-8"
Patrick Williams03907ee2022-05-01 06:28:52 -050078FILES:locale-base-ru-ru += "${datadir}/i18n/locales/musl/ru_RU.UTF-8"
Andrew Geisslerd5838332022-05-27 11:33:10 -050079FILES:locale-base-sr-rs += "${datadir}/i18n/locales/musl/sr_RS.UTF-8"
Patrick Williams03907ee2022-05-01 06:28:52 -050080FILES:locale-base-sv-se += "${datadir}/i18n/locales/musl/sv_SE.UTF-8"
81
82UPSTREAM_CHECK_COMMITS = "1"