blob: 0b5301cbff8530846a2af9af3971fb9b8f3b1d72 [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001# Copyright (C) 2017 Khem Raj <raj.khem@gmail.com>
2# Released under the MIT license (see COPYING.MIT for the terms)
3
4DESCRIPTION = "The LLVM Compiler Infrastructure"
5HOMEPAGE = "http://llvm.org"
Brad Bishopf3f93bb2019-10-16 14:33:32 -04006LICENSE = "Apache-2.0-with-LLVM-exception"
Brad Bishopd7bf8c12018-02-25 22:55:05 -05007SECTION = "devel"
8
Brad Bishopf3f93bb2019-10-16 14:33:32 -04009LIC_FILES_CHKSUM = "file://LICENSE.TXT;md5=8a15a0759ef07f2682d2ba4b893c9afe"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050010
Brad Bishop08902b02019-08-20 09:16:51 -040011DEPENDS = "libffi libxml2 zlib libedit ninja-native llvm-native"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050012
Patrick Williams213cb262021-08-07 19:21:33 -050013COMPATIBLE_HOST:riscv64 = "null"
14COMPATIBLE_HOST:riscv32 = "null"
Andrew Geissler82c905d2020-04-13 13:39:40 -050015
Patrick Williams213cb262021-08-07 19:21:33 -050016RDEPENDS:${PN}:append:class-target = " ncurses-terminfo"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050017
Brad Bishop19323692019-04-05 15:28:33 -040018inherit cmake pkgconfig
Brad Bishopd7bf8c12018-02-25 22:55:05 -050019
20PROVIDES += "llvm${PV}"
21
Andrew Geisslerd5838332022-05-27 11:33:10 -050022PV = "14.0.3"
Brad Bishopf3f93bb2019-10-16 14:33:32 -040023
Andrew Geissler5f350902021-07-23 13:09:54 -040024MAJOR_VERSION = "${@oe.utils.trim_version("${PV}", 1)}"
Brad Bishopf3f93bb2019-10-16 14:33:32 -040025
Brad Bishopd7bf8c12018-02-25 22:55:05 -050026LLVM_RELEASE = "${PV}"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050027
Brad Bishop19323692019-04-05 15:28:33 -040028BRANCH = "release/${MAJOR_VERSION}.x"
Andrew Geisslerd5838332022-05-27 11:33:10 -050029SRCREV = "1f9140064dfbfb0bbda8e51306ea51080b2f7aac"
Andrew Geissler595f6302022-01-24 19:11:47 +000030SRC_URI = "git://github.com/llvm/llvm-project.git;branch=${BRANCH};protocol=https \
Brad Bishop08902b02019-08-20 09:16:51 -040031 file://0006-llvm-TargetLibraryInfo-Undefine-libc-functions-if-th.patch;striplevel=2 \
32 file://0007-llvm-allow-env-override-of-exe-path.patch;striplevel=2 \
Andrew Geissler09209ee2020-12-13 08:44:15 -060033 file://0001-AsmMatcherEmitter-sort-ClassInfo-lists-by-name-as-we.patch;striplevel=2 \
34 "
Brad Bishop19323692019-04-05 15:28:33 -040035
Andrew Geissler82c905d2020-04-13 13:39:40 -050036UPSTREAM_CHECK_GITTAGREGEX = "llvmorg-(?P<pver>\d+(\.\d+)+)"
37
Brad Bishop19323692019-04-05 15:28:33 -040038S = "${WORKDIR}/git/llvm"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050039
40LLVM_INSTALL_DIR = "${WORKDIR}/llvm-install"
Brad Bishop19323692019-04-05 15:28:33 -040041
Brad Bishopd7bf8c12018-02-25 22:55:05 -050042def get_llvm_arch(bb, d, arch_var):
43 import re
44 a = d.getVar(arch_var)
Brad Bishop19323692019-04-05 15:28:33 -040045 if re.match(r'(i.86|athlon|x86.64)$', a): return 'X86'
46 elif re.match(r'arm$', a): return 'ARM'
47 elif re.match(r'armeb$', a): return 'ARM'
48 elif re.match(r'aarch64$', a): return 'AArch64'
49 elif re.match(r'aarch64_be$', a): return 'AArch64'
50 elif re.match(r'mips(isa|)(32|64|)(r6|)(el|)$', a): return 'Mips'
Brad Bishopf3f93bb2019-10-16 14:33:32 -040051 elif re.match(r'riscv(32|64)(eb|)$', a): return 'RISCV'
Brad Bishop19323692019-04-05 15:28:33 -040052 elif re.match(r'p(pc|owerpc)(|64)', a): return 'PowerPC'
Brad Bishopd7bf8c12018-02-25 22:55:05 -050053 else:
54 raise bb.parse.SkipRecipe("Cannot map '%s' to a supported LLVM architecture" % a)
55
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080056def get_llvm_host_arch(bb, d):
57 return get_llvm_arch(bb, d, 'HOST_ARCH')
58
Brad Bishopd7bf8c12018-02-25 22:55:05 -050059#
60# Default to build all OE-Core supported target arches (user overridable).
61#
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080062LLVM_TARGETS ?= "AMDGPU;${@get_llvm_host_arch(bb, d)}"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050063
Patrick Williams213cb262021-08-07 19:21:33 -050064ARM_INSTRUCTION_SET:armv5 = "arm"
65ARM_INSTRUCTION_SET:armv4t = "arm"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050066
67EXTRA_OECMAKE += "-DLLVM_ENABLE_ASSERTIONS=OFF \
68 -DLLVM_ENABLE_EXPENSIVE_CHECKS=OFF \
69 -DLLVM_ENABLE_PIC=ON \
70 -DLLVM_BINDINGS_LIST='' \
71 -DLLVM_LINK_LLVM_DYLIB=ON \
72 -DLLVM_ENABLE_FFI=ON \
Brad Bishop19323692019-04-05 15:28:33 -040073 -DLLVM_ENABLE_RTTI=ON \
Brad Bishopd7bf8c12018-02-25 22:55:05 -050074 -DFFI_INCLUDE_DIR=$(pkg-config --variable=includedir libffi) \
75 -DLLVM_OPTIMIZED_TABLEGEN=ON \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080076 -DLLVM_TARGETS_TO_BUILD='${LLVM_TARGETS}' \
Brad Bishop19323692019-04-05 15:28:33 -040077 -DLLVM_TEMPORARILY_ALLOW_OLD_TOOLCHAIN=ON \
Brad Bishop79641f22019-09-10 07:20:22 -040078 -DPYTHON_EXECUTABLE=${HOSTTOOLS_DIR}/python3 \
Brad Bishopd7bf8c12018-02-25 22:55:05 -050079 -G Ninja"
80
Patrick Williams213cb262021-08-07 19:21:33 -050081EXTRA_OECMAKE:append:class-target = "\
Brad Bishopd7bf8c12018-02-25 22:55:05 -050082 -DCMAKE_CROSSCOMPILING:BOOL=ON \
83 -DLLVM_TABLEGEN=${STAGING_BINDIR_NATIVE}/llvm-tblgen${PV} \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080084 -DLLVM_CONFIG_PATH=${STAGING_BINDIR_NATIVE}/llvm-config${PV} \
Brad Bishopd7bf8c12018-02-25 22:55:05 -050085 "
86
Patrick Williams213cb262021-08-07 19:21:33 -050087EXTRA_OECMAKE:append:class-nativesdk = "\
Brad Bishopd7bf8c12018-02-25 22:55:05 -050088 -DCMAKE_CROSSCOMPILING:BOOL=ON \
89 -DLLVM_TABLEGEN=${STAGING_BINDIR_NATIVE}/llvm-tblgen${PV} \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080090 -DLLVM_CONFIG_PATH=${STAGING_BINDIR_NATIVE}/llvm-config${PV} \
Brad Bishopd7bf8c12018-02-25 22:55:05 -050091 "
92
Andrew Geissler09209ee2020-12-13 08:44:15 -060093# patch out build host paths for reproducibility
Patrick Williams213cb262021-08-07 19:21:33 -050094do_compile:prepend:class-target() {
Andrew Geissler09209ee2020-12-13 08:44:15 -060095 sed -i -e "s,${WORKDIR},,g" ${B}/tools/llvm-config/BuildVariables.inc
96}
97
Brad Bishopd7bf8c12018-02-25 22:55:05 -050098do_compile() {
Brad Bishop316dfdd2018-06-25 12:45:53 -040099 ninja -v ${PARALLEL_MAKE}
Brad Bishopd7bf8c12018-02-25 22:55:05 -0500100}
101
Patrick Williams213cb262021-08-07 19:21:33 -0500102do_compile:class-native() {
Brad Bishop316dfdd2018-06-25 12:45:53 -0400103 ninja -v ${PARALLEL_MAKE} llvm-config llvm-tblgen
Brad Bishopd7bf8c12018-02-25 22:55:05 -0500104}
105
106do_install() {
Patrick Williams03907ee2022-05-01 06:28:52 -0500107 DESTDIR=${D} ninja -v install
Brad Bishopd7bf8c12018-02-25 22:55:05 -0500108
Patrick Williams03907ee2022-05-01 06:28:52 -0500109 # llvm harcodes usr/lib as install path, so this corrects it to actual libdir
110 mv -T -n ${D}/${prefix}/lib ${D}/${libdir} || true
Brad Bishopd7bf8c12018-02-25 22:55:05 -0500111
Patrick Williams03907ee2022-05-01 06:28:52 -0500112 # Remove opt-viewer: https://llvm.org/docs/Remarks.html
113 rm -rf ${D}${datadir}/opt-viewer
114 rmdir ${D}${datadir}
Brad Bishopd7bf8c12018-02-25 22:55:05 -0500115
Patrick Williams03907ee2022-05-01 06:28:52 -0500116 # reproducibility
117 sed -i -e 's,${WORKDIR},,g' ${D}/${libdir}/cmake/llvm/LLVMConfig.cmake
Brad Bishopd7bf8c12018-02-25 22:55:05 -0500118}
Brad Bishop19323692019-04-05 15:28:33 -0400119
Patrick Williams213cb262021-08-07 19:21:33 -0500120do_install:class-native() {
Brad Bishopd7bf8c12018-02-25 22:55:05 -0500121 install -D -m 0755 ${B}/bin/llvm-tblgen ${D}${bindir}/llvm-tblgen${PV}
122 install -D -m 0755 ${B}/bin/llvm-config ${D}${bindir}/llvm-config${PV}
Brad Bishopd7bf8c12018-02-25 22:55:05 -0500123}
124
Brad Bishop19323692019-04-05 15:28:33 -0400125PACKAGES =+ "${PN}-bugpointpasses ${PN}-llvmhello ${PN}-libllvm ${PN}-liboptremarks ${PN}-liblto"
Brad Bishopd7bf8c12018-02-25 22:55:05 -0500126
Patrick Williams213cb262021-08-07 19:21:33 -0500127RRECOMMENDS:${PN}-dev += "${PN}-bugpointpasses ${PN}-llvmhello ${PN}-liboptremarks"
Brad Bishopd7bf8c12018-02-25 22:55:05 -0500128
Patrick Williams213cb262021-08-07 19:21:33 -0500129FILES:${PN}-bugpointpasses = "\
Patrick Williams03907ee2022-05-01 06:28:52 -0500130 ${libdir}/BugpointPasses.so \
Brad Bishopd7bf8c12018-02-25 22:55:05 -0500131"
Brad Bishop19323692019-04-05 15:28:33 -0400132
Patrick Williams213cb262021-08-07 19:21:33 -0500133FILES:${PN}-libllvm = "\
Brad Bishop19323692019-04-05 15:28:33 -0400134 ${libdir}/libLLVM-${MAJOR_VERSION}.so \
135"
136
Patrick Williams213cb262021-08-07 19:21:33 -0500137FILES:${PN}-liblto += "\
Patrick Williams03907ee2022-05-01 06:28:52 -0500138 ${libdir}/libLTO.so.* \
Brad Bishopd7bf8c12018-02-25 22:55:05 -0500139"
140
Patrick Williams213cb262021-08-07 19:21:33 -0500141FILES:${PN}-liboptremarks += "\
Patrick Williams03907ee2022-05-01 06:28:52 -0500142 ${libdir}/libRemarks.so.* \
Brad Bishop19323692019-04-05 15:28:33 -0400143"
144
Patrick Williams213cb262021-08-07 19:21:33 -0500145FILES:${PN}-llvmhello = "\
Patrick Williams03907ee2022-05-01 06:28:52 -0500146 ${libdir}/LLVMHello.so \
Brad Bishopd7bf8c12018-02-25 22:55:05 -0500147"
148
Patrick Williams213cb262021-08-07 19:21:33 -0500149FILES:${PN}-dev += " \
Patrick Williams03907ee2022-05-01 06:28:52 -0500150 ${libdir}/llvm-config \
151 ${libdir}/libRemarks.so \
152 ${libdir}/libLLVM-${PV}.so \
Brad Bishop19323692019-04-05 15:28:33 -0400153"
Brad Bishopd7bf8c12018-02-25 22:55:05 -0500154
Patrick Williams213cb262021-08-07 19:21:33 -0500155FILES:${PN}-staticdev += "\
Patrick Williams03907ee2022-05-01 06:28:52 -0500156 ${libdir}/*.a \
Brad Bishop19323692019-04-05 15:28:33 -0400157"
Brad Bishopd7bf8c12018-02-25 22:55:05 -0500158
Patrick Williams213cb262021-08-07 19:21:33 -0500159INSANE_SKIP:${PN}-libllvm += "dev-so"
Brad Bishopd7bf8c12018-02-25 22:55:05 -0500160
161BBCLASSEXTEND = "native nativesdk"