blob: 443605ae261e68d0770896ada56acf09702cf57c [file] [log] [blame]
Andrew Geisslereff27472021-10-29 15:35:00 -05001SUMMARY = "Python GObject bindings"
2HOMEPAGE = "https://gitlab.gnome.org/GNOME/pygobject"
3DESCRIPTION = "PyGObject is a Python package which provides bindings for GObject based libraries such as GTK, GStreamer, WebKitGTK, GLib, GIO and many more."
4SECTION = "devel/python"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00005LICENSE = "LGPL-2.1-only"
Andrew Geisslereff27472021-10-29 15:35:00 -05006LIC_FILES_CHKSUM = "file://COPYING;md5=a916467b91076e631dd8edb7424769c7"
7
8GNOMEBASEBUILDCLASS = "meson"
Andrew Geissler595f6302022-01-24 19:11:47 +00009GIR_MESON_OPTION = ""
10
11inherit gnomebase setuptools3-base gobject-introspection upstream-version-is-even
Andrew Geisslereff27472021-10-29 15:35:00 -050012
13DEPENDS += "python3 glib-2.0"
14
Andrew Geisslereff27472021-10-29 15:35:00 -050015SRCNAME="pygobject"
16
17SRC_URI = " \
18 http://ftp.gnome.org/pub/GNOME/sources/${SRCNAME}/${@gnome_verdir("${PV}")}/${SRCNAME}-${PV}.tar.xz \
19 file://0001-Do-not-build-tests.patch \
20"
Andrew Geisslerd5838332022-05-27 11:33:10 -050021SRC_URI[sha256sum] = "1f34b5f7624de35e44eb5a7eb428353285bd03004d55131a5f7f7fa9b90f3cc9"
Andrew Geisslereff27472021-10-29 15:35:00 -050022
23S = "${WORKDIR}/${SRCNAME}-${PV}"
24
25PACKAGECONFIG ??= "${@bb.utils.contains_any('DISTRO_FEATURES', [ 'directfb', 'wayland', 'x11' ], 'cairo', '', d)}"
26
27RDEPENDS:${PN} += "python3-pkgutil"
28
29# python3-pycairo is checked on configuration -> DEPENDS
30# we don't link against python3-pycairo -> RDEPENDS
31PACKAGECONFIG[cairo] = "-Dpycairo=enabled,-Dpycairo=disabled, cairo python3-pycairo, python3-pycairo"
32
33BBCLASSEXTEND = "native"
34PACKAGECONFIG:class-native = ""