blob: e6f917b5cdc61d63375e6ea956b2ef24d67acc99 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "File synchronization tool"
2HOMEPAGE = "http://rsync.samba.org/"
Andrew Geissler90fd73c2021-03-05 15:25:55 -06003DESCRIPTION = "rsync is an open source utility that provides fast incremental file transfer."
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08004BUGTRACKER = "http://rsync.samba.org/bugzilla.html"
5SECTION = "console/network"
Andrew Geissler9aee5002022-03-30 16:27:02 +00006# GPL-2.0-or-later (<< 3.0.0), GPL-3.0-or-later (>= 3.0.0)
Andrew Geissler475cb722020-07-10 16:00:51 -05007# Includes opennsh and xxhash dynamic link exception
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00008LICENSE = "GPL-3.0-or-later"
Andrew Geisslerd5838332022-05-27 11:33:10 -05009LIC_FILES_CHKSUM = "file://COPYING;md5=24423708fe159c9d12be1ea29fcb18c7"
Brad Bishop316dfdd2018-06-25 12:45:53 -040010
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080011DEPENDS = "popt"
12
13SRC_URI = "https://download.samba.org/pub/${BPN}/src/${BP}.tar.gz \
14 file://rsyncd.conf \
15 file://makefile-no-rebuild.patch \
Andrew Geissler90fd73c2021-03-05 15:25:55 -060016 file://determism.patch \
Andrew Geissler475cb722020-07-10 16:00:51 -050017 "
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080018
Andrew Geisslerd5838332022-05-27 11:33:10 -050019SRC_URI[sha256sum] = "6f761838d08052b0b6579cf7f6737d93e47f01f4da04c5d24d3447b7f2a5fad1"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080020
Andrew Geissler82c905d2020-04-13 13:39:40 -050021# -16548 required for v3.1.3pre1. Already in v3.1.3.
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000022CVE_CHECK_IGNORE += " CVE-2017-16548 "
Andrew Geissler82c905d2020-04-13 13:39:40 -050023
Andrew Geissler475cb722020-07-10 16:00:51 -050024inherit autotools-brokensep
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080025
Brad Bishop316dfdd2018-06-25 12:45:53 -040026PACKAGECONFIG ??= "acl attr \
27 ${@bb.utils.filter('DISTRO_FEATURES', 'ipv6', d)} \
28"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080029
Brad Bishop316dfdd2018-06-25 12:45:53 -040030PACKAGECONFIG[acl] = "--enable-acl-support,--disable-acl-support,acl,"
31PACKAGECONFIG[attr] = "--enable-xattr-support,--disable-xattr-support,attr,"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080032PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6,"
Andrew Geissler475cb722020-07-10 16:00:51 -050033PACKAGECONFIG[lz4] = "--enable-lz4,--disable-lz4,lz4"
34PACKAGECONFIG[openssl] = "--enable-openssl,--disable-openssl,openssl"
35PACKAGECONFIG[xxhash] = "--enable-xxhash,--disable-xxhash,xxhash"
36PACKAGECONFIG[zstd] = "--enable-zstd,--disable-zstd,zstd"
Brad Bishop316dfdd2018-06-25 12:45:53 -040037
38# By default, if crosscompiling, rsync disables a number of
39# capabilities, hardlinking symlinks and special files (i.e. devices)
40CACHED_CONFIGUREVARS += "rsync_cv_can_hardlink_special=yes rsync_cv_can_hardlink_symlink=yes"
41
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080042EXTRA_OEMAKE = 'STRIP=""'
Andrew Geisslerd5838332022-05-27 11:33:10 -050043EXTRA_OECONF = "--disable-md2man --with-nobody-group=nogroup"
44
45#| ./simd-checksum-x86_64.cpp: In function 'uint32_t get_checksum1_cpp(char*, int32_t)':
46#| ./simd-checksum-x86_64.cpp:89:52: error: multiversioning needs 'ifunc' which is not supported on this target
47#| 89 | __attribute__ ((target("default"))) MVSTATIC int32 get_checksum1_avx2_64(schar* buf, int32 len, int32 i, uint32* ps1, uint32* ps2) { return i; }
48#| | ^~~~~~~~~~~~~~~~~~~~~
49#| ./simd-checksum-x86_64.cpp:480:1: error: use of multiversioned function without a default
50#| 480 | }
51#| | ^
52#| If you can't fix the issue, re-run ./configure with --disable-roll-simd.
53EXTRA_OECONF:append:libc-musl = " --disable-roll-simd"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080054
Brad Bishop316dfdd2018-06-25 12:45:53 -040055# rsync 3.0 uses configure.sh instead of configure, and
56# makefile checks the existence of configure.sh
Patrick Williams213cb262021-08-07 19:21:33 -050057do_configure:prepend () {
Brad Bishop316dfdd2018-06-25 12:45:53 -040058 rm -f ${S}/configure ${S}/configure.sh
59}
60
Patrick Williams213cb262021-08-07 19:21:33 -050061do_configure:append () {
Brad Bishop316dfdd2018-06-25 12:45:53 -040062 cp -f ${S}/configure ${S}/configure.sh
63}
64
Patrick Williams213cb262021-08-07 19:21:33 -050065do_install:append() {
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080066 install -d ${D}${sysconfdir}
67 install -m 0644 ${WORKDIR}/rsyncd.conf ${D}${sysconfdir}
68}
69
Andrew Geissler6ce62a22020-11-30 19:58:47 -060070BBCLASSEXTEND = "native nativesdk"