blob: 67081bb8cb48db661ceb1e6aeec24937906db493 [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "The Cairo 2D vector graphics library"
2DESCRIPTION = "Cairo is a multi-platform library providing anti-aliased \
3vector-based rendering for multiple target backends. Paths consist \
4of line segments and cubic splines and can be rendered at any width \
5with various join and cap styles. All colors may be specified with \
6optional translucence (opacity/alpha) and combined using the \
7extended Porter/Duff compositing algebra as found in the X Render \
8Extension."
9HOMEPAGE = "http://cairographics.org"
10BUGTRACKER = "http://bugs.freedesktop.org"
11SECTION = "libs"
12
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000013LICENSE = "(MPL-1.1 | LGPL-2.1-only) & GPL-3.0-or-later"
14LICENSE:${PN} = "MPL-1.1 | LGPL-2.1-only"
15LICENSE:${PN}-dev = "MPL-1.1 | LGPL-2.1-only"
16LICENSE:${PN}-doc = "MPL-1.1 | LGPL-2.1-only"
17LICENSE:${PN}-gobject = "MPL-1.1 | LGPL-2.1-only"
18LICENSE:${PN}-script-interpreter = "MPL-1.1 | LGPL-2.1-only"
19LICENSE:${PN}-perf-utils = "GPL-3.0-or-later"
Brad Bishop19323692019-04-05 15:28:33 -040020
Andrew Geisslerd5838332022-05-27 11:33:10 -050021LIC_FILES_CHKSUM = "file://COPYING;md5=e73e999e0c72b5ac9012424fa157ad77 \
22 file://util/cairo-trace/COPYING-GPL-3;md5=d32239bcb673463ab874e80d47fae504"
23
Brad Bishop19323692019-04-05 15:28:33 -040024
25DEPENDS = "fontconfig glib-2.0 libpng pixman zlib"
26
27SRC_URI = "http://cairographics.org/releases/cairo-${PV}.tar.xz \
Andrew Geissler4ed12e12020-06-05 18:00:41 -050028 file://cairo-get_bitmap_surface-bsc1036789-CVE-2017-7475.diff \
Brad Bishop19323692019-04-05 15:28:33 -040029 file://CVE-2018-19876.patch \
30 file://CVE-2019-6461.patch \
31 file://CVE-2019-6462.patch \
William A. Kennington IIIac69b482021-06-02 12:28:27 -070032 file://CVE-2020-35492.patch \
Brad Bishop19323692019-04-05 15:28:33 -040033 "
34
35SRC_URI[md5sum] = "f19e0353828269c22bd72e271243a552"
36SRC_URI[sha256sum] = "5e7b29b3f113ef870d1e3ecf8adf21f923396401604bda16d44be45e66052331"
37
38inherit autotools pkgconfig upstream-version-is-even gtk-doc multilib_script
39
40MULTILIB_SCRIPTS = "${PN}-perf-utils:${bindir}/cairo-trace"
41
42X11DEPENDS = "virtual/libx11 libsm libxrender libxext"
43
44PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'directfb', d)} \
45 ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11 xcb', '', d)} \
Andrew Geissler82c905d2020-04-13 13:39:40 -050046 ${@bb.utils.contains('DISTRO_FEATURES', 'x11 opengl', 'opengl', '', d)} \
47 trace"
Patrick Williams213cb262021-08-07 19:21:33 -050048PACKAGECONFIG:class-native = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11 xcb', '', d)}"
49PACKAGECONFIG:class-nativesdk = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11 xcb', '', d)}"
Brad Bishop19323692019-04-05 15:28:33 -040050
51PACKAGECONFIG[x11] = "--with-x=yes -enable-xlib,--with-x=no --disable-xlib,${X11DEPENDS}"
52PACKAGECONFIG[xcb] = "--enable-xcb,--disable-xcb,libxcb"
53PACKAGECONFIG[directfb] = "--enable-directfb=yes,,directfb"
54PACKAGECONFIG[valgrind] = "--enable-valgrind=yes,--disable-valgrind,valgrind"
55PACKAGECONFIG[egl] = "--enable-egl=yes,--disable-egl,virtual/egl"
56PACKAGECONFIG[glesv2] = "--enable-glesv2,--disable-glesv2,virtual/libgles2"
57PACKAGECONFIG[opengl] = "--enable-gl,--disable-gl,virtual/libgl"
Andrew Geisslerd5838332022-05-27 11:33:10 -050058# trace is under GPLv3
Andrew Geissler82c905d2020-04-13 13:39:40 -050059PACKAGECONFIG[trace] = "--enable-trace,--disable-trace"
Brad Bishop19323692019-04-05 15:28:33 -040060
61EXTRA_OECONF += " \
62 ${@bb.utils.contains('TARGET_FPU', 'soft', '--disable-some-floating-point', '', d)} \
63 --enable-tee \
64"
65
66# We don't depend on binutils so we need to disable this
67export ac_cv_lib_bfd_bfd_openr="no"
68# Ensure we don't depend on LZO
69export ac_cv_lib_lzo2_lzo2a_decompress="no"
70
Patrick Williams213cb262021-08-07 19:21:33 -050071do_install:append () {
Brad Bishop19323692019-04-05 15:28:33 -040072 rm -rf ${D}${bindir}/cairo-sphinx
73 rm -rf ${D}${libdir}/cairo/cairo-fdr*
74 rm -rf ${D}${libdir}/cairo/cairo-sphinx*
75 rm -rf ${D}${libdir}/cairo/.debug/cairo-fdr*
76 rm -rf ${D}${libdir}/cairo/.debug/cairo-sphinx*
Andrew Geissler4ed12e12020-06-05 18:00:41 -050077 [ ! -d ${D}${bindir} ] ||
78 rmdir -p --ignore-fail-on-non-empty ${D}${bindir}
79 [ ! -d ${D}${libdir}/cairo ] ||
80 rmdir -p --ignore-fail-on-non-empty ${D}${libdir}/cairo
Brad Bishop19323692019-04-05 15:28:33 -040081}
82
83PACKAGES =+ "cairo-gobject cairo-script-interpreter cairo-perf-utils"
84
Patrick Williams213cb262021-08-07 19:21:33 -050085SUMMARY:cairo-gobject = "The Cairo library GObject wrapper library"
86DESCRIPTION:cairo-gobject = "A GObject wrapper library for the Cairo API."
Brad Bishop19323692019-04-05 15:28:33 -040087
Patrick Williams213cb262021-08-07 19:21:33 -050088SUMMARY:cairo-script-interpreter = "The Cairo library script interpreter"
89DESCRIPTION:cairo-script-interpreter = "The Cairo script interpreter implements \
Brad Bishop19323692019-04-05 15:28:33 -040090CairoScript. CairoScript is used by tracing utilities to enable the ability \
91to replay rendering."
92
Patrick Williams213cb262021-08-07 19:21:33 -050093DESCRIPTION:cairo-perf-utils = "The Cairo library performance utilities"
Brad Bishop19323692019-04-05 15:28:33 -040094
Patrick Williams213cb262021-08-07 19:21:33 -050095FILES:${PN} = "${libdir}/libcairo.so.*"
96FILES:${PN}-gobject = "${libdir}/libcairo-gobject.so.*"
97FILES:${PN}-script-interpreter = "${libdir}/libcairo-script-interpreter.so.*"
98FILES:${PN}-perf-utils = "${bindir}/cairo-trace* ${libdir}/cairo/*.la ${libdir}/cairo/libcairo-trace.so"
Brad Bishop19323692019-04-05 15:28:33 -040099
100BBCLASSEXTEND = "native nativesdk"
101
102UPSTREAM_CHECK_REGEX = "cairo-(?P<pver>\d+(\.\d+)+).tar.xz"