blob: 727c1702882e64fffd1d9cd10e8787d700ba0abc [file] [log] [blame]
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00001SUMMARY = "Framework for layout and rendering of internationalized text"
2DESCRIPTION = "Pango is a library for laying out and rendering of text, \
3with an emphasis on internationalization. Pango can be used anywhere \
4that text layout is needed, though most of the work on Pango so far has \
5been done in the context of the GTK+ widget toolkit. Pango forms the \
6core of text and font handling for GTK+-2.x."
7HOMEPAGE = "http://www.pango.org/"
8BUGTRACKER = "http://bugzilla.gnome.org"
9SECTION = "libs"
10LICENSE = "LGPL-2.0-or-later"
11
12LIC_FILES_CHKSUM = "file://COPYING;md5=3bf50002aefd002f49e7bb854063f7e7"
13
14GNOMEBASEBUILDCLASS = "meson"
15
16inherit gnomebase gi-docgen ptest-gnome upstream-version-is-even gobject-introspection
17
18GIR_MESON_ENABLE_FLAG = "enabled"
19GIR_MESON_DISABLE_FLAG = "disabled"
20
Patrick Williams03907ee2022-05-01 06:28:52 -050021SRC_URI += "file://run-ptest \
22 file://0001-Skip-running-test-layout-test.patch \
23"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000024
Andrew Geisslerd5838332022-05-27 11:33:10 -050025SRC_URI[archive.sha256sum] = "0477f369a3d4c695df7299a6989dc004756a7f4de27eecac405c6790b7e3ad33"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000026
27DEPENDS = "glib-2.0 glib-2.0-native fontconfig freetype virtual/libiconv cairo harfbuzz fribidi"
28
29PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'x11', d)} \
30 ${@bb.utils.contains('PTEST_ENABLED', '1', 'tests', '', d)}"
31
32PACKAGECONFIG[x11] = ",,virtual/libx11 libxft"
33PACKAGECONFIG[tests] = "-Dinstall-tests=true, -Dinstall-tests=false"
34PACKAGECONFIG[thai] = ",,libthai"
35
36GIR_MESON_OPTION = 'introspection'
37
38do_configure:prepend() {
39 chmod +x ${S}/tests/*.py
40}
41
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000042LEAD_SONAME = "libpango-1.0*"
43
44FILES:${PN} = "${bindir}/* ${libdir}/libpango*${SOLIBS}"
45
46RDEPENDS:${PN}-ptest += "cantarell-fonts"
47RDEPENDS:${PN}-ptest:append:libc-glibc = " locale-base-en-us"
48
49RPROVIDES:${PN} += "pango-modules pango-module-indic-lang \
50 pango-module-basic-fc pango-module-arabic-lang"
51
52BBCLASSEXTEND = "native nativesdk"