blob: a5e6b906d2b4f5a5d718430cc3b921c0cb5c2dbd [file] [log] [blame]
Andrew Geissler9aee5002022-03-30 16:27:02 +00001SECTION = "devel"
2SUMMARY = "Linux Trace Toolkit KERNEL MODULE"
3DESCRIPTION = "The lttng-modules 2.0 package contains the kernel tracer modules"
4HOMEPAGE = "https://lttng.org/"
5LICENSE = "LGPL-2.1-only & GPL-2.0-only & MIT"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=0464cff101a009c403cd2ed65d01d4c4"
7
8inherit module
9
10include lttng-platforms.inc
11
Patrick Williams03907ee2022-05-01 06:28:52 -050012SRC_URI = "https://lttng.org/files/${BPN}/${BPN}-${PV}.tar.bz2 \
13 file://0001-Fix-compaction-migratepages-event-name.patch \
14 file://0002-Fix-tracepoint-event-allow-same-provider-and-event-n.patch \
15 file://0003-fix-sched-tracing-Don-t-re-read-p-state-when-emittin.patch \
16 file://0004-fix-block-remove-genhd.h-v5.18.patch \
17 file://0005-fix-scsi-block-Remove-REQ_OP_WRITE_SAME-support-v5.1.patch \
18 file://0006-fix-random-remove-unused-tracepoints-v5.18.patch \
19 file://0007-fix-kprobes-Use-rethook-for-kretprobe-if-possible-v5.patch \
20 file://0008-fix-scsi-core-Remove-scsi-scsi_request.h-v5.18.patch \
21 file://0009-Rename-genhd-wrapper-to-blkdev.patch \
22 file://0010-fix-mm-compaction-cleanup-the-compaction-trace-event.patch \
Andrew Geisslerd5838332022-05-27 11:33:10 -050023 file://0001-fix-sched-tracing-Append-prev_state-to-tp-args-inste.patch \
Patrick Williams03907ee2022-05-01 06:28:52 -050024 "
25
Andrew Geissler9aee5002022-03-30 16:27:02 +000026# Use :append here so that the patch is applied also when using devupstream
27SRC_URI:append = " file://0001-src-Kbuild-change-missing-CONFIG_TRACEPOINTS-to-warn.patch"
28
29SRC_URI[sha256sum] = "7cf1acbb50b84116acc9b4281b81dcc2643d6018bbd1e8514ad1270239896c4b"
30
31export INSTALL_MOD_DIR="kernel/lttng-modules"
32
33EXTRA_OEMAKE += "KERNELDIR='${STAGING_KERNEL_DIR}'"
34
35MODULES_MODULE_SYMVERS_LOCATION = "src"
36
37do_install:append() {
38 # Delete empty directories to avoid QA failures if no modules were built
39 if [ -d ${D}/${nonarch_base_libdir} ]; then
40 find ${D}/${nonarch_base_libdir} -depth -type d -empty -exec rmdir {} \;
41 fi
42}
43
44python do_package:prepend() {
45 if not os.path.exists(os.path.join(d.getVar('D'), d.getVar('nonarch_base_libdir')[1:], 'modules')):
46 bb.warn("%s: no modules were created; this may be due to CONFIG_TRACEPOINTS not being enabled in your kernel." % d.getVar('PN'))
47}
48
49BBCLASSEXTEND = "devupstream:target"
50SRC_URI:class-devupstream = "git://git.lttng.org/lttng-modules;branch=stable-2.13"
51SRCREV:class-devupstream = "7584cfc04914cb0842a986e9808686858b9c8630"
52SRCREV_FORMAT ?= "lttng_git"