blob: f7108013d349873d5e1a93a3e3fb88713329e846 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "General purpose cryptographic library based on the code from GnuPG"
Andrew Geissler90fd73c2021-03-05 15:25:55 -06002DESCRIPTION = "A cryptography library developed as a separated module of GnuPG. \
3It can also be used independently of GnuPG, but depends on its error-reporting \
4library Libgpg-error."
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08005HOMEPAGE = "http://directory.fsf.org/project/libgcrypt/"
6BUGTRACKER = "https://bugs.g10code.com/gnupg/index"
7SECTION = "libs"
8
9# helper program gcryptrnd and getrandom are under GPL, rest LGPL
Andrew Geisslerd5838332022-05-27 11:33:10 -050010LICENSE = "GPL-2.0-or-later & LGPL-2.1-or-later"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000011LICENSE:${PN} = "LGPL-2.1-or-later"
12LICENSE:${PN}-dev = "GPL-2.0-or-later & LGPL-2.1-or-later"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080013
14LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
15 file://COPYING.LIB;md5=bbb461211a33b134d42ed5ee802b37ff \
Patrick Williams03907ee2022-05-01 06:28:52 -050016 file://LICENSES;md5=ef545b6cc717747072616519a1256d69 \
Andrew Geissler90fd73c2021-03-05 15:25:55 -060017 "
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080018
19DEPENDS = "libgpg-error"
Andrew Geisslerd5838332022-05-27 11:33:10 -050020RDEPENDS:${PN}-ptest = "bash make"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080021
22UPSTREAM_CHECK_URI = "https://gnupg.org/download/index.html"
23SRC_URI = "${GNUPG_MIRROR}/libgcrypt/libgcrypt-${PV}.tar.bz2 \
Brad Bishop64c979e2019-11-04 13:55:29 -050024 file://0001-libgcrypt-fix-m4-file-for-oe-core.patch \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080025 file://0003-tests-bench-slope.c-workaround-ICE-failure-on-mips-w.patch \
26 file://0002-libgcrypt-fix-building-error-with-O2-in-sysroot-path.patch \
27 file://0004-tests-Makefile.am-fix-undefined-reference-to-pthread.patch \
Andrew Geisslerd5838332022-05-27 11:33:10 -050028 file://run-ptest \
Andrew Geissler90fd73c2021-03-05 15:25:55 -060029 "
Patrick Williams03907ee2022-05-01 06:28:52 -050030SRC_URI[sha256sum] = "ef14ae546b0084cd84259f61a55e07a38c3b53afc0f546bffcef2f01baffe9de"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080031
Andrew Geisslerd1e89492021-02-12 15:35:20 -060032# Below whitelisted CVEs are disputed and not affecting crypto libraries for any distro.
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000033CVE_CHECK_IGNORE += "CVE-2018-12433 CVE-2018-12438"
Andrew Geisslerd1e89492021-02-12 15:35:20 -060034
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080035BINCONFIG = "${bindir}/libgcrypt-config"
36
Andrew Geisslerd5838332022-05-27 11:33:10 -050037inherit autotools texinfo binconfig-disabled pkgconfig ptest
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080038
39EXTRA_OECONF = "--disable-asm"
Patrick Williams213cb262021-08-07 19:21:33 -050040EXTRA_OEMAKE:class-target = "LIBTOOLFLAGS='--tag=CC'"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080041
Andrew Geisslerd5838332022-05-27 11:33:10 -050042PRIVATE_LIBS:${PN}-ptest:append = " libgcrypt.so.20"
43
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080044PACKAGECONFIG ??= "capabilities"
45PACKAGECONFIG[capabilities] = "--with-capabilities,--without-capabilities,libcap"
46
Patrick Williams213cb262021-08-07 19:21:33 -050047do_configure:prepend () {
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080048 # Else this could be used in preference to the one in aclocal-copy
49 rm -f ${S}/m4/gpg-error.m4
50}
51
52# libgcrypt.pc is added locally and thus installed here
Patrick Williams213cb262021-08-07 19:21:33 -050053do_install:append() {
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080054 install -d ${D}/${libdir}/pkgconfig
55 install -m 0644 ${B}/src/libgcrypt.pc ${D}/${libdir}/pkgconfig/
56}
57
Andrew Geisslerd5838332022-05-27 11:33:10 -050058do_install_ptest() {
59 cp -r --preserve=mode,links -v ${S} ${D}${PTEST_PATH}
60 cp -r --preserve=mode,links -v ${B} ${D}${PTEST_PATH}
61 rm ${D}${PTEST_PATH}/build/cipher/gost-s-box
62 rm ${D}${PTEST_PATH}/build/doc/yat2m
63 rm ${D}${PTEST_PATH}/build/libtool
64 rm ${D}${PTEST_PATH}/build/config.status
65 rm ${D}${PTEST_PATH}/build/config.log
66 rm ${D}${PTEST_PATH}/build/src/mpicalc
67 rm ${D}${PTEST_PATH}/${BP}/autom4te* -rf
68 sed -i -e 's/Makefile:.*/Makefile-disabled:/' ${D}${PTEST_PATH}/build/Makefile
69 find ${D}/${PTEST_PATH}/build -name "*.cmake" -or -name "Makefile" \
70 | xargs sed -e "s|${WORKDIR}|${PTEST_PATH}|g" -e "s|${WORKDIR}/recipe-sysroot-native||g" -i
71}
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080072
Andrew Geisslerd5838332022-05-27 11:33:10 -050073FILES:${PN}-dev += "${bindir}/hmac256 ${bindir}/dumpsexp"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080074
75BBCLASSEXTEND = "native nativesdk"