blob: 61623ac98de01d02f8430f572b1480114772d9f4 [file] [log] [blame]
Andrew Geisslerd688a012020-09-18 13:36:00 -05001SUMMARY = "Meta-python ptest packagegroups"
Brad Bishop19323692019-04-05 15:28:33 -04002
3inherit packagegroup
4
5PROVIDES = "${PACKAGES}"
6PACKAGES = ' \
Brad Bishop19323692019-04-05 15:28:33 -04007 packagegroup-meta-python3 \
8'
9
Brad Bishop19323692019-04-05 15:28:33 -040010RDEPENDS_packagegroup-meta-python3 = "\
11 packagegroup-meta-python3-extended \
12 packagegroup-meta-python3-connectivity \
13"
14
Brad Bishop19323692019-04-05 15:28:33 -040015RDEPENDS_packagegroup-meta-python3 = "\
Andrew Geisslerd688a012020-09-18 13:36:00 -050016 pamela \
17 pyrtm \
Brad Bishop19323692019-04-05 15:28:33 -040018 ${@bb.utils.contains("DISTRO_FEATURES", "systemd", "python3-systemd", "", d)} \
Andrew Geisslerd688a012020-09-18 13:36:00 -050019 python3-bcrypt \
20 python3-flask-mail \
21 python3-editor \
22 python3-flask-pymongo \
23 python3-cffi \
24 python3-pillow \
25 python3-markupsafe \
26 python3-flask-nav \
27 python3-asciitree \
28 python3-flask-sqlalchemy \
29 python3-gevent \
30 python3-attrs \
31 python3-aenum \
32 python3-gast \
33 python3-blinker \
34 python3-prettytable \
35 python3-cmd2 \
36 python3-aiofiles \
37 python3-anyjson \
38 python3-isodate \
39 python3-incremental \
40 python3-aiohttp-jinja2 \
41 python3-aiohttp \
42 python3-alembic \
43 python3-ansi2html \
44 python3-ansicolors \
45 python3-argexec \
46 python3-appdirs \
47 python3-apply-defaults \
48 python3-argh \
49 python3-ply \
50 python3-astroid \
51 python3-ndg-httpsclient \
52 python3-arpeggio \
53 python3-astor \
54 python3-pika \
55 python3-asn1crypto \
56 python3-async-timeout \
57 python3-absl \
58 python3-atomicwrites \
59 python3-attr \
60 python3-flask \
61 python3-autobahn \
62 python3-babel \
63 python3-pretend \
64 python3-automat \
65 python3-ptyprocess \
66 python3-aws-iot-device-sdk-python \
67 python3-bandit \
68 python3-backcall \
69 python3-backports-functools-lru-cache \
70 python3-beautifulsoup4 \
71 python3-betamax \
72 python3-behave \
73 python3-jsonpointer \
74 python3-bitarray \
75 python3-bitstring \
76 python3-bitstruct \
77 python3-cachecontrol \
78 python3-booleanpy \
79 python3-cachetools \
80 python3-can \
81 python3-cantools \
82 python3-cassandra-driver \
83 python3-cbor2 \
84 python3-chardet \
85 python3-certifi \
86 python3-isort \
87 python3-colorama \
88 python3-cheetah \
89 python3-click \
90 python3-huey \
91 python3-coloredlogs \
92 python3-colorlog \
93 python3-wheel \
94 python3-configshell-fb \
95 python3-constantly \
96 python3-contextlib2 \
97 python3-configargparse \
98 python3-crcmod \
99 python3-configobj \
100 python3-configparser \
101 python3-cppy \
102 python3-dbussy \
103 python3-dateutil \
104 python3-distro \
105 python3-click-repl \
106 python3-redis \
107 python3-dominate \
108 python3-et-xmlfile \
109 python3-feedformatter \
110 python3-flask-jsonpify \
111 python3-flask-jwt \
112 python3-flask-migrate \
113 python3-pyinotify \
114 python3-flask-restful \
115 python3-flask-socketio \
116 python3-gmqtt \
117 python3-dateparser \
118 python3-defusedxml \
119 python3-rsa \
120 python3-django-south \
121 python3-grpcio \
122 python3-pybind11-json \
123 python3-google-api-python-client \
124 python3-h5py \
125 python3-dt-schema \
126 python3-haversine \
127 python3-fasteners \
128 python3-flask-bootstrap \
129 python3-dbus-next \
130 python3-dnspython \
131 python3-traitlets \
132 python3-pybind11 \
133 python3-flask-script \
134 python3-flask-sijax \
135 python3-html2text \
136 python3-html5lib \
137 python3-intervals \
138 python3-ipy \
139 python3-ipaddress \
140 python3-iso8601 \
141 python3-humanfriendly \
142 python3-lrparsing \
143 python3-itsdangerous \
144 python3-hyperlink \
145 python3-idna-ssl \
146 python3-jdcal \
147 python3-greenstalk \
148 python3-icu \
149 python3-jsonschema \
150 python3-keras-applications \
151 python3-idna \
152 python3-sympy \
153 python3-importlib-metadata \
154 python3-langtable \
155 python3-lockfile \
156 python3-nmap \
157 python3-jdatetime \
158 python3-monotonic \
159 python3-mpmath \
160 python3-jedi \
161 python3-jsonpatch \
162 python3-jsonrpcserver \
163 python3-libconf \
164 python3-netifaces \
165 python3-msm \
166 python3-nocaselist \
167 python3-keras-preprocessing \
168 python3-flask-babel \
169 python3-lorem \
170 python3-javaobj-py3 \
171 python3-passlib \
172 python3-pathlib2 \
173 python3-pexpect \
174 python3-luma-oled \
175 python3-pluggy \
176 python3-lxml \
177 python3-precise-runner \
178 python3-padaos \
179 python3-progress \
180 python3-sqlalchemy \
181 python3-sh \
182 python3-petact \
183 python3-mock \
184 python3-msgpack \
185 python3-pyasn1 \
186 python3-msk \
187 python3-openpyxl \
188 python3-prctl \
189 python3-pyatspi \
190 python3-multidict \
191 python3-netaddr \
192 python3-parse \
193 python3-oauthlib \
194 python3-pyfirmata \
195 python3-pandas \
196 python3-padatious \
197 python3-prompt-toolkit \
198 python3-parse-type \
199 python3-cycler \
200 python3-decorator \
201 python3-django \
202 python3-croniter \
203 python3-flask-user \
204 python3-twitter \
205 python3-evdev \
206 python3-dynamic-dispatch \
207 python3-click-spinner \
208 python3-future \
209 python3-geojson \
210 python3-gunicorn \
211 python3-engineio \
212 python3-gmpy2 \
213 python3-coverage \
214 python3-fastnumbers \
215 python3-fann2 \
216 python3-gnupg \
217 python3-flask-login \
218 python3-pyzmq \
219 python3-cryptography-vectors \
220 python3-flask-uploads \
221 python3-ecdsa \
222 python3-networkx \
223 python3-flask-xstatic \
224 python3-pint \
225 python3-iso3166 \
226 python3-imageio \
227 python3-mccabe \
228 python3-kconfiglib \
229 python3-grpcio-tools \
230 python3-jinja2 \
231 python3-jsmin \
232 python3-greenlet \
233 python3-idna \
234 python3-flask-versioned \
235 python3-httplib2 \
236 python3-ipython-genutils \
237 python3-kiwisolver \
238 python3-lz4 \
239 python3-obd \
240 python3-markdown \
241 python3-m2crypto \
242 python3-paho-mqtt \
243 python3-graphviz \
244 python3-pyaudio \
245 python3-pako \
246 python3-meld3 \
247 python3-parallax \
248 python3-lazy-object-proxy \
249 python3-license-expression \
250 python3-luma-core \
251 python3-natsort \
252 python3-polyline \
253 python3-ordered-set \
254 python3-packaging \
255 python3-parso \
256 python3-pycparser \
257 python3-pycrypto \
258 python3-pydbus \
259 python3-pathtools3 \
260 python3-periphery \
261 python3-pyiface \
262 python3-pyjwt \
263 python3-pykwalify \
264 python3-pylint \
265 python3-pynetlinux \
266 python3-pickleshare \
267 python3-pyopenssl \
268 python3-protobuf \
269 python3-py \
270 python3-pyasn1-modules \
271 python3-pyscaffold \
272 python3-pyserial \
273 python3-pysocks \
274 python3-pytoml \
275 python3-pytest-helpers-namespace \
276 python3-more-itertools \
277 python3-pytest-tempdir \
278 python3-pyflakes \
279 python3-pyrad \
280 python3-pyusb \
281 python3-pyhamcrest \
282 python3-custom-inherit \
283 python3-pymysql \
284 python3-pyperclip \
285 python3-rfc3339-validator \
286 python3-pytz \
287 python3-scrypt \
288 python3-rdflib \
289 python3-sijax \
290 python3-regex \
291 python3-slip-dbus \
292 python3-smbus2 \
293 python3-pytest-metadata \
294 python3-term \
295 python3-pystache \
296 python3-pep8 \
297 python3-pytest-runner \
298 python3-pybluez \
299 python3-rfc3986-validator \
300 python3-pocketsphinx \
301 python3-sdnotify \
302 python3-pycodestyle \
303 python3-pytest \
304 python3-speaklater \
305 python3-wtforms \
306 python3-speedtest-cli \
307 python3-pyudev \
308 python3-sqlparse \
309 python3-pyexpect \
310 python3-pytest-html \
311 python3-uritemplate \
312 python3-cryptography \
313 python3-requests \
314 python3-test-generator \
315 python3-whoosh \
316 python3-xstatic-font-awesome \
317 python3-tqdm \
318 python3-vcversioner \
319 python3-semver \
320 python3-serpent \
321 python3-spidev \
322 python3-sqlsoup \
323 python3-tornado \
324 python3-trafaret \
325 python3-urllib3 \
326 python3-yappi \
327 python3-zipp \
328 python3-texttable \
329 python3-humanize \
330 python3-strict-rfc3339 \
331 python3-supervisor \
332 python3-toml \
333 python3-diskcache \
334 python3-requests-futures \
335 python3-matplotlib \
336 python3-sentry-sdk \
337 python3-xlrd \
338 python3-xstatic \
339 python3-tzlocal \
340 python3-wcwidth \
341 python3-ntplib \
342 python3-u-msgpack-python \
343 python3-python-vlc \
344 python3-xlsxwriter \
345 python3-inflection \
346 python3-tabulate \
347 python3-typing-extensions \
348 python3-pystemd \
349 python3-pid \
350 python3-pkgconfig \
351 python3-pylyrics \
352 python3-pyyaml \
353 python3-raven \
354 python3-stevedore \
355 python3-requests-oauthlib \
356 python3-rfc3987 \
357 python3-psutil \
358 python3-robotframework-seriallibrary \
359 python3-pulsectl \
360 python3-py-ubjson \
361 python3-pyalsaaudio \
362 python3-simpleeval \
363 python3-smbus \
364 python3-pychromecast \
365 python3-pyjks \
366 python3-pymongo \
367 python3-spidev \
368 python3-pynacl \
369 python3-termcolor \
370 python3-pyperf \
371 python3-qrcode \
372 python3-visitor \
373 python3-pyroute2 \
374 python3-webencodings \
375 python3-pyrsistent \
376 python3-werkzeug \
377 python3-pydicti \
378 python3-xmlrunner \
379 python3-smpplib \
380 python3-pymisp \
381 python3-requests-file \
382 python3-requests-toolbelt \
383 python3-ruamel-yaml \
384 python3-setuptools-scm \
385 python3-socketio \
386 python3-soupsieve \
387 python3-textparser \
388 python3-tinyrecord \
389 python3-twine \
390 python3-unidiff \
391 python3-watchdog \
392 python3-webcolors \
393 python3-robotframework \
394 python3-xxhash \
395 python3-yarl \
396 python3-zopeinterface \
397 python3-requests-ftp \
398 python3-scapy \
399 python3-paramiko \
400 python3-twofish \
401 python3-simplejson \
402 python3-snappy \
403 python3-versiontools \
404 python3-flask-wtf \
405 python3-websockets \
406 python3-werkzeug \
407 python3-wrapt \
408 python3-xmltodict \
409 python3-trafaret-config \
410 python3-twisted \
411 python3-txaio \
412 python3-typeguard \
413 python3-pytest-timeout \
414 python3-ujson \
415 python3-waitress \
416 python3-websocket-client \
417 python3-xmodem \
418 python3-djangorestframework \
419 python3-pytest-asyncio \
420 python3-nocasedict \
421 python3-yamlloader \
422 python3-ipython \
423 python3-pycurl \
424 gyp \
425 python3-jsonref \
Brad Bishop19323692019-04-05 15:28:33 -0400426"
427
Brad Bishop19323692019-04-05 15:28:33 -0400428RDEPENDS_packagegroup-meta-python3-extended = "\
Brad Bishop19323692019-04-05 15:28:33 -0400429 python3-blivet \
Brad Bishop19323692019-04-05 15:28:33 -0400430 ${@bb.utils.contains("DISTRO_FEATURES", "x11", "python3-blivetgui", "", d)} \
Andrew Geisslerd688a012020-09-18 13:36:00 -0500431 python3-cson \
432 python3-meh \
433 python3-pyephem \
434 python3-pykickstart \
435 python3-pyparted \
436 python3-pywbem \
437 python3-pywbemtools \
Brad Bishop19323692019-04-05 15:28:33 -0400438"
439
Brad Bishop19323692019-04-05 15:28:33 -0400440RDEPENDS_packagegroup-meta-python3-connectivity = "\
Brad Bishop19323692019-04-05 15:28:33 -0400441 python3-gsocketpool \
Andrew Geisslerd688a012020-09-18 13:36:00 -0500442 python3-h2 \
443 python3-hpack \
444 python3-hyperframe \
445 python3-mprpc \
446 python3-priority \
447 python3-pyconnman \
448 python3-pyro4 \
449 python3-thrift \
450 python3-txws \
451 python3-pytun \
452 telepathy-python3 \
Brad Bishop19323692019-04-05 15:28:33 -0400453"
454
Brad Bishop19323692019-04-05 15:28:33 -0400455RDEPENDS_packagegroup-meta-python3-ptest = "\
Andrew Geisslerd688a012020-09-18 13:36:00 -0500456 python3-cryptography-ptest \
Brad Bishop19323692019-04-05 15:28:33 -0400457 "
458
459EXCLUDE_FROM_WORLD = "1"