blob: db01d743311bdb49fcac8821e5e7b0e7d34c7dab [file] [log] [blame]
Patrick Williams8b8bc412016-08-17 15:02:23 -05001SUMMARY = "A commandline OMX player for the Raspberry Pi"
2DESCRIPTION = "This player was developed as a testbed for the XBMC \
3Raspberry PI implementation and is quite handy to use standalone"
4HOMEPAGE = "https://github.com/popcornmix/omxplayer"
5SECTION = "console/utils"
6
7LICENSE = "GPLv2"
8LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
9
Brad Bishop6e60e8b2018-02-01 10:27:11 -050010DEPENDS = "libpcre libav virtual/egl boost freetype dbus openssl samba libssh libomxil coreutils-native curl-native"
Patrick Williams8b8bc412016-08-17 15:02:23 -050011PR = "r4"
12
Brad Bishopd7bf8c12018-02-25 22:55:05 -050013SRCREV_default = "b8ff59dccd9307f10dad71bec2525a95bd6c603b"
14
15# omxplayer builds its own copy of ffmpeg from source instead of using the
16# system's ffmpeg library. This isn't ideal but it's ok for now. We do however
17# want to keep control of the exact version of ffmpeg used instead of just
18# fetching the latest commit on a release branch (which is what the checkout job
19# in Makefile.ffmpeg in the omxplayer source tree does).
20#
21# This SRCREV corresponds to the v3.1.10 release of ffmpeg.
22SRCREV_ffmpeg = "afa34cb36edca0ff809b7e58474bbce12271ecba"
23
Patrick Williams8b8bc412016-08-17 15:02:23 -050024SRC_URI = "git://github.com/popcornmix/omxplayer.git;protocol=git;branch=master \
Brad Bishopd7bf8c12018-02-25 22:55:05 -050025 git://source.ffmpeg.org/ffmpeg;branch=release/3.1;protocol=git;depth=1;name=ffmpeg;destsuffix=git/ffmpeg \
Patrick Williams8b8bc412016-08-17 15:02:23 -050026 file://0001-Remove-Makefile.include-which-includes-hardcoded.patch \
27 file://0002-Libraries-and-headers-from-ffmpeg-are-installed-in-u.patch \
28 file://0003-Remove-strip-step-in-Makefile.patch \
29 file://0004-Add-FFMPEG_EXTRA_CFLAGS-and-FFMPEG_EXTRA_LDFLAGS.patch \
30 file://fix-tar-command-with-DIST.patch \
31 file://use-native-pkg-config.patch \
Brad Bishopd7bf8c12018-02-25 22:55:05 -050032 file://0005-Don-t-require-internet-connection-during-build.patch \
33 file://0006-Prevent-ffmpeg-configure-compile-race-condition.patch \
Patrick Williams8b8bc412016-08-17 15:02:23 -050034 "
35S = "${WORKDIR}/git"
36
Brad Bishop6e60e8b2018-02-01 10:27:11 -050037COMPATIBLE_MACHINE ?= "null"
38COMPATIBLE_MACHINE_rpi_aarch64 = "null"
39COMPATIBLE_MACHINE_rpi = "(.*)"
Patrick Williams8b8bc412016-08-17 15:02:23 -050040
41inherit autotools-brokensep pkgconfig
42
43# Needed in ffmpeg configure
44export TEMPDIR = "${S}/tmp"
45
46# Needed in Makefile.ffmpeg
47export HOST = "${HOST_SYS}"
48export WORK = "${S}"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050049export FFMPEG_EXTRA_CFLAGS = "${TUNE_CCARGS} ${TOOLCHAIN_OPTIONS}"
50export FFMPEG_EXTRA_LDFLAGS = "${TUNE_CCARGS} ${TOOLCHAIN_OPTIONS}"
Patrick Williams8b8bc412016-08-17 15:02:23 -050051
52# Needed in top Makefile
53export LDFLAGS = "-L${S}/ffmpeg_compiled/usr/lib \
54 -L${STAGING_DIR_HOST}/lib \
55 -L${STAGING_DIR_HOST}/usr/lib \
56 "
57export INCLUDES = "-isystem${STAGING_DIR_HOST}/usr/include/interface/vcos/pthreads \
58 -isystem${STAGING_DIR_HOST}/usr/include/freetype2 \
59 -isystem${STAGING_DIR_HOST}/usr/include/interface/vmcs_host/linux \
60 -isystem${STAGING_DIR_HOST}/usr/include/dbus-1.0 \
61 -isystem${STAGING_DIR_HOST}/usr/lib/dbus-1.0/include \
62 "
63export DIST = "${D}"
64
65do_compile() {
66 # Needed for compiler test in ffmpeg's configure
67 mkdir -p tmp
68
Brad Bishopd7bf8c12018-02-25 22:55:05 -050069 oe_runmake -f Makefile.ffmpeg
70 oe_runmake -f Makefile.ffmpeg install
Patrick Williams8b8bc412016-08-17 15:02:23 -050071 oe_runmake
72}
73
74do_install() {
75 oe_runmake STRIP='echo skipping strip' dist
76 mkdir -p ${D}${datadir}/fonts/truetype/freefont/
77 install ${S}/fonts/* ${D}${datadir}/fonts/truetype/freefont/
78}
79
80FILES_${PN} = "${bindir}/omxplayer* \
81 ${libdir}/omxplayer/lib*${SOLIBS} \
82 ${datadir}/fonts"
83
84FILES_${PN}-dev += "${libdir}/omxplayer/*.so"
85
86RDEPENDS_${PN} += "bash procps"