blob: ec80ad47a405270ed81ac3c9e0afa6860f25792e [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001# ex:ts=4:sw=4:sts=4:et
2# -*- tab-width: 4; c-basic-offset: 4; indent-tabs-mode: nil -*-
3#
4# This bbclass is used for creating archive for:
5# 1) original (or unpacked) source: ARCHIVER_MODE[src] = "original"
6# 2) patched source: ARCHIVER_MODE[src] = "patched" (default)
7# 3) configured source: ARCHIVER_MODE[src] = "configured"
8# 4) The patches between do_unpack and do_patch:
9# ARCHIVER_MODE[diff] = "1"
10# And you can set the one that you'd like to exclude from the diff:
11# ARCHIVER_MODE[diff-exclude] ?= ".pc autom4te.cache patches"
12# 5) The environment data, similar to 'bitbake -e recipe':
13# ARCHIVER_MODE[dumpdata] = "1"
14# 6) The recipe (.bb and .inc): ARCHIVER_MODE[recipe] = "1"
15# 7) Whether output the .src.rpm package:
16# ARCHIVER_MODE[srpm] = "1"
17# 8) Filter the license, the recipe whose license in
18# COPYLEFT_LICENSE_INCLUDE will be included, and in
19# COPYLEFT_LICENSE_EXCLUDE will be excluded.
20# COPYLEFT_LICENSE_INCLUDE = 'GPL* LGPL*'
21# COPYLEFT_LICENSE_EXCLUDE = 'CLOSED Proprietary'
22# 9) The recipe type that will be archived:
23# COPYLEFT_RECIPE_TYPES = 'target'
24#
25
26# Don't filter the license by default
27COPYLEFT_LICENSE_INCLUDE ?= ''
28COPYLEFT_LICENSE_EXCLUDE ?= ''
29# Create archive for all the recipe types
30COPYLEFT_RECIPE_TYPES ?= 'target native nativesdk cross crosssdk cross-canadian'
31inherit copyleft_filter
32
33ARCHIVER_MODE[srpm] ?= "0"
34ARCHIVER_MODE[src] ?= "patched"
35ARCHIVER_MODE[diff] ?= "0"
36ARCHIVER_MODE[diff-exclude] ?= ".pc autom4te.cache patches"
37ARCHIVER_MODE[dumpdata] ?= "0"
38ARCHIVER_MODE[recipe] ?= "0"
39
40DEPLOY_DIR_SRC ?= "${DEPLOY_DIR}/sources"
41ARCHIVER_TOPDIR ?= "${WORKDIR}/deploy-sources"
42ARCHIVER_OUTDIR = "${ARCHIVER_TOPDIR}/${TARGET_SYS}/${PF}/"
43ARCHIVER_WORKDIR = "${WORKDIR}/archiver-work/"
44
45do_dumpdata[dirs] = "${ARCHIVER_OUTDIR}"
46do_ar_recipe[dirs] = "${ARCHIVER_OUTDIR}"
47do_ar_original[dirs] = "${ARCHIVER_OUTDIR} ${ARCHIVER_WORKDIR}"
48do_deploy_archives[dirs] = "${WORKDIR}"
49do_deploy_all_archives[dirs] = "${WORKDIR}"
50
51# This is a convenience for the shell script to use it
52
53
54python () {
Brad Bishop6e60e8b2018-02-01 10:27:11 -050055 pn = d.getVar('PN')
56 assume_provided = (d.getVar("ASSUME_PROVIDED") or "").split()
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050057 if pn in assume_provided:
Brad Bishop6e60e8b2018-02-01 10:27:11 -050058 for p in d.getVar("PROVIDES").split():
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050059 if p != pn:
60 pn = p
61 break
Patrick Williamsc124f4f2015-09-15 14:41:29 -050062
63 included, reason = copyleft_should_include(d)
64 if not included:
65 bb.debug(1, 'archiver: %s is excluded: %s' % (pn, reason))
66 return
67 else:
68 bb.debug(1, 'archiver: %s is included: %s' % (pn, reason))
69
Brad Bishop6e60e8b2018-02-01 10:27:11 -050070
71 # glibc-locale: do_fetch, do_unpack and do_patch tasks have been deleted,
72 # so avoid archiving source here.
73 if pn.startswith('glibc-locale'):
74 return
75
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050076 # We just archive gcc-source for all the gcc related recipes
Brad Bishop6e60e8b2018-02-01 10:27:11 -050077 if d.getVar('BPN') in ['gcc', 'libgcc'] \
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050078 and not pn.startswith('gcc-source'):
79 bb.debug(1, 'archiver: %s is excluded, covered by gcc-source' % pn)
80 return
81
Brad Bishop6e60e8b2018-02-01 10:27:11 -050082 ar_src = d.getVarFlag('ARCHIVER_MODE', 'src')
83 ar_dumpdata = d.getVarFlag('ARCHIVER_MODE', 'dumpdata')
84 ar_recipe = d.getVarFlag('ARCHIVER_MODE', 'recipe')
Patrick Williamsc124f4f2015-09-15 14:41:29 -050085
86 if ar_src == "original":
87 d.appendVarFlag('do_deploy_archives', 'depends', ' %s:do_ar_original' % pn)
Brad Bishop6e60e8b2018-02-01 10:27:11 -050088 # 'patched' and 'configured' invoke do_unpack_and_patch because
89 # do_ar_patched resp. do_ar_configured depend on it, but for 'original'
90 # we have to add it explicitly.
91 if d.getVarFlag('ARCHIVER_MODE', 'diff') == '1':
92 d.appendVarFlag('do_deploy_archives', 'depends', ' %s:do_unpack_and_patch' % pn)
Patrick Williamsc124f4f2015-09-15 14:41:29 -050093 elif ar_src == "patched":
94 d.appendVarFlag('do_deploy_archives', 'depends', ' %s:do_ar_patched' % pn)
95 elif ar_src == "configured":
96 # We can't use "addtask do_ar_configured after do_configure" since it
97 # will cause the deptask of do_populate_sysroot to run not matter what
98 # archives we need, so we add the depends here.
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050099
100 # There is a corner case with "gcc-source-${PV}" recipes, they don't have
101 # the "do_configure" task, so we need to use "do_preconfigure"
102 if pn.startswith("gcc-source-"):
103 d.appendVarFlag('do_ar_configured', 'depends', ' %s:do_preconfigure' % pn)
104 else:
105 d.appendVarFlag('do_ar_configured', 'depends', ' %s:do_configure' % pn)
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500106 d.appendVarFlag('do_deploy_archives', 'depends', ' %s:do_ar_configured' % pn)
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500107
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500108 elif ar_src:
109 bb.fatal("Invalid ARCHIVER_MODE[src]: %s" % ar_src)
110
111 if ar_dumpdata == "1":
112 d.appendVarFlag('do_deploy_archives', 'depends', ' %s:do_dumpdata' % pn)
113
114 if ar_recipe == "1":
115 d.appendVarFlag('do_deploy_archives', 'depends', ' %s:do_ar_recipe' % pn)
116
117 # Output the srpm package
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500118 ar_srpm = d.getVarFlag('ARCHIVER_MODE', 'srpm')
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500119 if ar_srpm == "1":
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500120 if d.getVar('PACKAGES') != '' and d.getVar('IMAGE_PKGTYPE') == 'rpm':
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500121 d.appendVarFlag('do_deploy_archives', 'depends', ' %s:do_package_write_rpm' % pn)
122 if ar_dumpdata == "1":
123 d.appendVarFlag('do_package_write_rpm', 'depends', ' %s:do_dumpdata' % pn)
124 if ar_recipe == "1":
125 d.appendVarFlag('do_package_write_rpm', 'depends', ' %s:do_ar_recipe' % pn)
126 if ar_src == "original":
127 d.appendVarFlag('do_package_write_rpm', 'depends', ' %s:do_ar_original' % pn)
128 elif ar_src == "patched":
129 d.appendVarFlag('do_package_write_rpm', 'depends', ' %s:do_ar_patched' % pn)
130 elif ar_src == "configured":
131 d.appendVarFlag('do_package_write_rpm', 'depends', ' %s:do_ar_configured' % pn)
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500132}
133
134# Take all the sources for a recipe and puts them in WORKDIR/archiver-work/.
135# Files in SRC_URI are copied directly, anything that's a directory
136# (e.g. git repositories) is "unpacked" and then put into a tarball.
137python do_ar_original() {
138
Brad Bishop37a0e4d2017-12-04 01:01:44 -0500139 import shutil, tempfile
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500140
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500141 if d.getVarFlag('ARCHIVER_MODE', 'src') != "original":
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500142 return
143
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500144 ar_outdir = d.getVar('ARCHIVER_OUTDIR')
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500145 bb.note('Archiving the original source...')
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500146 urls = d.getVar("SRC_URI").split()
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600147 # destsuffix (git fetcher) and subdir (everything else) are allowed to be
148 # absolute paths (for example, destsuffix=${S}/foobar).
149 # That messes with unpacking inside our tmpdir below, because the fetchers
150 # will then unpack in that directory and completely ignore the tmpdir.
151 # That breaks parallel tasks relying on ${S}, like do_compile.
152 #
153 # To solve this, we remove these parameters from all URLs.
154 # We do this even for relative paths because it makes the content of the
155 # archives more useful (no extra paths that are only used during
156 # compilation).
157 for i, url in enumerate(urls):
158 decoded = bb.fetch2.decodeurl(url)
159 for param in ('destsuffix', 'subdir'):
160 if param in decoded[5]:
161 del decoded[5][param]
162 encoded = bb.fetch2.encodeurl(decoded)
163 urls[i] = encoded
164 fetch = bb.fetch2.Fetch(urls, d)
165 tarball_suffix = {}
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500166 for url in fetch.urls:
167 local = fetch.localpath(url).rstrip("/");
168 if os.path.isfile(local):
169 shutil.copy(local, ar_outdir)
170 elif os.path.isdir(local):
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500171 tmpdir = tempfile.mkdtemp(dir=d.getVar('ARCHIVER_WORKDIR'))
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500172 fetch.unpack(tmpdir, (url,))
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600173 # To handle recipes with more than one source, we add the "name"
174 # URL parameter as suffix. We treat it as an error when
175 # there's more than one URL without a name, or a name gets reused.
176 # This is an additional safety net, in practice the name has
177 # to be set when using the git fetcher, otherwise SRCREV cannot
178 # be set separately for each URL.
179 params = bb.fetch2.decodeurl(url)[5]
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500180 type = bb.fetch2.decodeurl(url)[0]
181 location = bb.fetch2.decodeurl(url)[2]
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600182 name = params.get('name', '')
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500183 if type.lower() == 'file':
184 name_tmp = location.rstrip("*").rstrip("/")
185 name = os.path.basename(name_tmp)
186 else:
187 if name in tarball_suffix:
188 if not name:
189 bb.fatal("Cannot determine archive names for original source because 'name' URL parameter is unset in more than one URL. Add it to at least one of these: %s %s" % (tarball_suffix[name], url))
190 else:
191 bb.fatal("Cannot determine archive names for original source because 'name=' URL parameter '%s' is used twice. Make it unique in: %s %s" % (tarball_suffix[name], url))
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600192 tarball_suffix[name] = url
193 create_tarball(d, tmpdir + '/.', name, ar_outdir)
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500194
195 # Emit patch series files for 'original'
196 bb.note('Writing patch series files...')
197 for patch in src_patches(d):
198 _, _, local, _, _, parm = bb.fetch.decodeurl(patch)
199 patchdir = parm.get('patchdir')
200 if patchdir:
201 series = os.path.join(ar_outdir, 'series.subdir.%s' % patchdir.replace('/', '_'))
202 else:
203 series = os.path.join(ar_outdir, 'series')
204
205 with open(series, 'a') as s:
206 s.write('%s -p%s\n' % (os.path.basename(local), parm['striplevel']))
207}
208
209python do_ar_patched() {
210
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500211 if d.getVarFlag('ARCHIVER_MODE', 'src') != 'patched':
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500212 return
213
214 # Get the ARCHIVER_OUTDIR before we reset the WORKDIR
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500215 ar_outdir = d.getVar('ARCHIVER_OUTDIR')
216 ar_workdir = d.getVar('ARCHIVER_WORKDIR')
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500217 bb.note('Archiving the patched source...')
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500218 d.setVar('WORKDIR', ar_workdir)
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500219 create_tarball(d, d.getVar('S'), 'patched', ar_outdir)
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500220}
221
222python do_ar_configured() {
223 import shutil
224
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500225 # Forcibly expand the sysroot paths as we're about to change WORKDIR
Brad Bishopd7bf8c12018-02-25 22:55:05 -0500226 d.setVar('STAGING_DIR_HOST', d.getVar('STAGING_DIR_HOST'))
227 d.setVar('STAGING_DIR_TARGET', d.getVar('STAGING_DIR_TARGET'))
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500228 d.setVar('RECIPE_SYSROOT', d.getVar('RECIPE_SYSROOT'))
229 d.setVar('RECIPE_SYSROOT_NATIVE', d.getVar('RECIPE_SYSROOT_NATIVE'))
230
231 ar_outdir = d.getVar('ARCHIVER_OUTDIR')
232 if d.getVarFlag('ARCHIVER_MODE', 'src') == 'configured':
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500233 bb.note('Archiving the configured source...')
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500234 pn = d.getVar('PN')
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500235 # "gcc-source-${PV}" recipes don't have "do_configure"
236 # task, so we need to run "do_preconfigure" instead
237 if pn.startswith("gcc-source-"):
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500238 d.setVar('WORKDIR', d.getVar('ARCHIVER_WORKDIR'))
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500239 bb.build.exec_func('do_preconfigure', d)
240
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500241 # The libtool-native's do_configure will remove the
242 # ${STAGING_DATADIR}/aclocal/libtool.m4, so we can't re-run the
243 # do_configure, we archive the already configured ${S} to
244 # instead of.
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500245 elif pn != 'libtool-native':
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500246 # Change the WORKDIR to make do_configure run in another dir.
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500247 d.setVar('WORKDIR', d.getVar('ARCHIVER_WORKDIR'))
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500248 if bb.data.inherits_class('kernel-yocto', d):
249 bb.build.exec_func('do_kernel_configme', d)
250 if bb.data.inherits_class('cmake', d):
251 bb.build.exec_func('do_generate_toolchain_file', d)
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500252 prefuncs = d.getVarFlag('do_configure', 'prefuncs')
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500253 for func in (prefuncs or '').split():
254 if func != "sysroot_cleansstate":
255 bb.build.exec_func(func, d)
256 bb.build.exec_func('do_configure', d)
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500257 postfuncs = d.getVarFlag('do_configure', 'postfuncs')
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500258 for func in (postfuncs or '').split():
259 if func != "do_qa_configure":
260 bb.build.exec_func(func, d)
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500261 srcdir = d.getVar('S')
262 builddir = d.getVar('B')
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500263 if srcdir != builddir:
264 if os.path.exists(builddir):
265 oe.path.copytree(builddir, os.path.join(srcdir, \
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500266 'build.%s.ar_configured' % d.getVar('PF')))
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500267 create_tarball(d, srcdir, 'configured', ar_outdir)
268}
269
Patrick Williamsf1e5d692016-03-30 15:21:19 -0500270def create_tarball(d, srcdir, suffix, ar_outdir):
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500271 """
272 create the tarball from srcdir
273 """
274 import tarfile
275
Patrick Williamsf1e5d692016-03-30 15:21:19 -0500276 # Make sure we are only creating a single tarball for gcc sources
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500277 if (d.getVar('SRC_URI') == ""):
Patrick Williamsf1e5d692016-03-30 15:21:19 -0500278 return
279
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500280 bb.utils.mkdirhier(ar_outdir)
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500281 if suffix:
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500282 filename = '%s-%s.tar.gz' % (d.getVar('PF'), suffix)
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500283 else:
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500284 filename = '%s.tar.gz' % d.getVar('PF')
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500285 tarname = os.path.join(ar_outdir, filename)
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500286
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500287 bb.note('Creating %s' % tarname)
288 tar = tarfile.open(tarname, 'w:gz')
Brad Bishop37a0e4d2017-12-04 01:01:44 -0500289 tar.add(srcdir, arcname=os.path.basename(srcdir))
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500290 tar.close()
291
292# creating .diff.gz between source.orig and source
293def create_diff_gz(d, src_orig, src, ar_outdir):
294
295 import subprocess
296
297 if not os.path.isdir(src) or not os.path.isdir(src_orig):
298 return
299
300 # The diff --exclude can't exclude the file with path, so we copy
301 # the patched source, and remove the files that we'd like to
302 # exclude.
303 src_patched = src + '.patched'
304 oe.path.copyhardlinktree(src, src_patched)
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500305 for i in d.getVarFlag('ARCHIVER_MODE', 'diff-exclude').split():
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500306 bb.utils.remove(os.path.join(src_orig, i), recurse=True)
307 bb.utils.remove(os.path.join(src_patched, i), recurse=True)
308
309 dirname = os.path.dirname(src)
310 basename = os.path.basename(src)
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500311 bb.utils.mkdirhier(ar_outdir)
312 cwd = os.getcwd()
313 try:
314 os.chdir(dirname)
315 out_file = os.path.join(ar_outdir, '%s-diff.gz' % d.getVar('PF'))
316 diff_cmd = 'diff -Naur %s.orig %s.patched | gzip -c > %s' % (basename, basename, out_file)
317 subprocess.check_call(diff_cmd, shell=True)
318 bb.utils.remove(src_patched, recurse=True)
319 finally:
320 os.chdir(cwd)
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500321
322# Run do_unpack and do_patch
323python do_unpack_and_patch() {
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500324 if d.getVarFlag('ARCHIVER_MODE', 'src') not in \
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500325 [ 'patched', 'configured'] and \
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500326 d.getVarFlag('ARCHIVER_MODE', 'diff') != '1':
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500327 return
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500328 ar_outdir = d.getVar('ARCHIVER_OUTDIR')
329 ar_workdir = d.getVar('ARCHIVER_WORKDIR')
330 ar_sysroot_native = d.getVar('STAGING_DIR_NATIVE')
331 pn = d.getVar('PN')
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500332
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500333 # The kernel class functions require it to be on work-shared, so we dont change WORKDIR
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600334 if not (bb.data.inherits_class('kernel-yocto', d) or pn.startswith('gcc-source')):
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500335 # Change the WORKDIR to make do_unpack do_patch run in another dir.
336 d.setVar('WORKDIR', ar_workdir)
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500337 # Restore the original path to recipe's native sysroot (it's relative to WORKDIR).
338 d.setVar('STAGING_DIR_NATIVE', ar_sysroot_native)
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500339
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500340 # The changed 'WORKDIR' also caused 'B' changed, create dir 'B' for the
341 # possibly requiring of the following tasks (such as some recipes's
342 # do_patch required 'B' existed).
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500343 bb.utils.mkdirhier(d.getVar('B'))
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500344
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500345 bb.build.exec_func('do_unpack', d)
346
347 # Save the original source for creating the patches
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500348 if d.getVarFlag('ARCHIVER_MODE', 'diff') == '1':
349 src = d.getVar('S').rstrip('/')
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500350 src_orig = '%s.orig' % src
351 oe.path.copytree(src, src_orig)
Patrick Williamsf1e5d692016-03-30 15:21:19 -0500352
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500353 # Make sure gcc and kernel sources are patched only once
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500354 if not (d.getVar('SRC_URI') == "" or (bb.data.inherits_class('kernel-yocto', d) or pn.startswith('gcc-source'))):
Patrick Williamsf1e5d692016-03-30 15:21:19 -0500355 bb.build.exec_func('do_patch', d)
356
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500357 # Create the patches
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500358 if d.getVarFlag('ARCHIVER_MODE', 'diff') == '1':
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500359 bb.note('Creating diff gz...')
360 create_diff_gz(d, src_orig, src, ar_outdir)
361 bb.utils.remove(src_orig, recurse=True)
362}
363
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500364# BBINCLUDED is special (excluded from basehash signature
365# calculation). Using it in a task signature can cause "basehash
366# changed" errors.
367#
368# Depending on BBINCLUDED also causes do_ar_recipe to run again
369# for unrelated changes, like adding or removing buildhistory.bbclass.
370#
371# For these reasons we ignore the dependency completely. The versioning
372# of the output file ensures that we create it each time the recipe
373# gets rebuilt, at least as long as a PR server is used. We also rely
374# on that mechanism to catch changes in the file content, because the
375# file content is not part of of the task signature either.
376do_ar_recipe[vardepsexclude] += "BBINCLUDED"
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500377python do_ar_recipe () {
378 """
379 archive the recipe, including .bb and .inc.
380 """
381 import re
382 import shutil
383
384 require_re = re.compile( r"require\s+(.+)" )
385 include_re = re.compile( r"include\s+(.+)" )
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500386 bbfile = d.getVar('FILE')
387 outdir = os.path.join(d.getVar('WORKDIR'), \
388 '%s-recipe' % d.getVar('PF'))
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500389 bb.utils.mkdirhier(outdir)
390 shutil.copy(bbfile, outdir)
391
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500392 pn = d.getVar('PN')
393 bbappend_files = d.getVar('BBINCLUDED').split()
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500394 # If recipe name is aa, we need to match files like aa.bbappend and aa_1.1.bbappend
395 # Files like aa1.bbappend or aa1_1.1.bbappend must be excluded.
Brad Bishop37a0e4d2017-12-04 01:01:44 -0500396 bbappend_re = re.compile( r".*/%s_[^/]*\.bbappend$" % re.escape(pn))
397 bbappend_re1 = re.compile( r".*/%s\.bbappend$" % re.escape(pn))
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500398 for file in bbappend_files:
399 if bbappend_re.match(file) or bbappend_re1.match(file):
400 shutil.copy(file, outdir)
401
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500402 dirname = os.path.dirname(bbfile)
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500403 bbpath = '%s:%s' % (dirname, d.getVar('BBPATH'))
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500404 f = open(bbfile, 'r')
405 for line in f.readlines():
406 incfile = None
407 if require_re.match(line):
408 incfile = require_re.match(line).group(1)
409 elif include_re.match(line):
410 incfile = include_re.match(line).group(1)
411 if incfile:
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500412 incfile = d.expand(incfile)
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500413 incfile = bb.utils.which(bbpath, incfile)
414 if incfile:
415 shutil.copy(incfile, outdir)
416
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500417 create_tarball(d, outdir, 'recipe', d.getVar('ARCHIVER_OUTDIR'))
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500418 bb.utils.remove(outdir, recurse=True)
419}
420
421python do_dumpdata () {
422 """
423 dump environment data to ${PF}-showdata.dump
424 """
425
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500426 dumpfile = os.path.join(d.getVar('ARCHIVER_OUTDIR'), \
427 '%s-showdata.dump' % d.getVar('PF'))
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500428 bb.note('Dumping metadata into %s' % dumpfile)
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500429 with open(dumpfile, "w") as f:
430 # emit variables and shell functions
431 bb.data.emit_env(f, d, True)
432 # emit the metadata which isn't valid shell
433 for e in d.keys():
434 if d.getVarFlag(e, "python", False):
435 f.write("\npython %s () {\n%s}\n" % (e, d.getVar(e, False)))
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500436}
437
438SSTATETASKS += "do_deploy_archives"
439do_deploy_archives () {
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500440 echo "Deploying source archive files from ${ARCHIVER_TOPDIR} to ${DEPLOY_DIR_SRC}."
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500441}
442python do_deploy_archives_setscene () {
443 sstate_setscene(d)
444}
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500445do_deploy_archives[dirs] = "${ARCHIVER_TOPDIR}"
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500446do_deploy_archives[sstate-inputdirs] = "${ARCHIVER_TOPDIR}"
447do_deploy_archives[sstate-outputdirs] = "${DEPLOY_DIR_SRC}"
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500448addtask do_deploy_archives_setscene
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500449
450addtask do_ar_original after do_unpack
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500451addtask do_unpack_and_patch after do_patch
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500452addtask do_ar_patched after do_unpack_and_patch
453addtask do_ar_configured after do_unpack_and_patch
454addtask do_dumpdata
455addtask do_ar_recipe
456addtask do_deploy_archives before do_build
457
458addtask do_deploy_all_archives after do_deploy_archives
459do_deploy_all_archives[recrdeptask] = "do_deploy_archives"
460do_deploy_all_archives[recideptask] = "do_${BB_DEFAULT_TASK}"
461do_deploy_all_archives() {
462 :
463}
Patrick Williamsf1e5d692016-03-30 15:21:19 -0500464
465python () {
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500466 # Add tasks in the correct order, specifically for linux-yocto to avoid race condition.
467 # sstatesig.py:sstate_rundepfilter has special support that excludes this dependency
468 # so that do_kernel_configme does not need to run again when do_unpack_and_patch
469 # gets added or removed (by adding or removing archiver.bbclass).
Patrick Williamsf1e5d692016-03-30 15:21:19 -0500470 if bb.data.inherits_class('kernel-yocto', d):
471 bb.build.addtask('do_kernel_configme', 'do_configure', 'do_unpack_and_patch', d)
Patrick Williamsf1e5d692016-03-30 15:21:19 -0500472}