blob: de779e94aae857086ddec6d53f3265185d10b07d [file] [log] [blame]
Patrick Williamsc0f7c042017-02-23 20:41:17 -06001SUMMARY = "Compressor/archiver for creating and modifying .zip files"
2HOMEPAGE = "http://www.info-zip.org"
3SECTION = "console/utils"
Patrick Williamsc124f4f2015-09-15 14:41:29 -05004
Patrick Williamsc0f7c042017-02-23 20:41:17 -06005LICENSE = "BSD-3-Clause"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=04d43c5d70b496c032308106e26ae17d"
Patrick Williamsc124f4f2015-09-15 14:41:29 -05007
Patrick Williamsc0f7c042017-02-23 20:41:17 -06008PR = "r2"
9
Patrick Williamsc124f4f2015-09-15 14:41:29 -050010S = "${WORKDIR}/zip30"
11
Patrick Williamsc0f7c042017-02-23 20:41:17 -060012SRC_URI = "${SOURCEFORGE_MIRROR}/infozip/Zip%203.x%20%28latest%29/3.0/zip30.tar.gz \
13 file://fix-security-format.patch"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050014UPSTREAM_VERSION_UNKNOWN = "1"
Patrick Williamsc0f7c042017-02-23 20:41:17 -060015
Patrick Williamsc124f4f2015-09-15 14:41:29 -050016SRC_URI[md5sum] = "7b74551e63f8ee6aab6fbc86676c0d37"
17SRC_URI[sha256sum] = "f0e8bb1f9b7eb0b01285495a2699df3a4b766784c1765a8f1aeedf63c0806369"
18
Patrick Williamsc124f4f2015-09-15 14:41:29 -050019# zip.inc sets CFLAGS, but what Makefile actually uses is
20# CFLAGS_NOOPT. It will also force -O3 optimization, overriding
21# whatever we set.
Patrick Williamsc0f7c042017-02-23 20:41:17 -060022EXTRA_OEMAKE = "'CC=${CC}' 'BIND=${CC}' 'AS=${CC} -c' 'CPP=${CPP}' \
23 'CFLAGS=-I. -DUNIX ${CFLAGS}' \
24 'CFLAGS_NOOPT=-I. -DUNIX ${CFLAGS}' \
25 'INSTALL=install' 'INSTALL_D=install -d' \
26 'BINFLAGS=0755'"
27
28do_compile() {
29 oe_runmake -f unix/Makefile flags IZ_BZIP2=no_such_directory
30 sed -i 's#LFLAGS1=""#LFLAGS1="${LDFLAGS}"#' flags
31 oe_runmake -f unix/Makefile generic IZ_BZIP2=no_such_directory
32}
33
34do_install() {
35 oe_runmake -f unix/Makefile prefix=${D}${prefix} \
36 BINDIR=${D}${bindir} MANDIR=${D}${mandir}/man1 \
37 install
38}
39
40BBCLASSEXTEND = "native"
41
42# exclude version 2.3.2 which triggers a false positive
43UPSTREAM_CHECK_REGEX = "^zip(?P<pver>(?!232).+)\.tgz"