blob: 475b2073f1d5faf39dc66aa0127c6483a198ea4a [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "Script-directed dynamic tracing and performance analysis tool for Linux"
Brad Bishopd7bf8c12018-02-25 22:55:05 -05002HOMEPAGE = "https://sourceware.org/systemtap/"
Patrick Williamsc124f4f2015-09-15 14:41:29 -05003
4require systemtap_git.inc
5
Patrick Williamsc0f7c042017-02-23 20:41:17 -06006DEPENDS = "boost elfutils"
Patrick Williamsc124f4f2015-09-15 14:41:29 -05007
Brad Bishop37a0e4d2017-12-04 01:01:44 -05008RDEPENDS_${PN} += "python3-core bash perl"
Patrick Williamsc124f4f2015-09-15 14:41:29 -05009
10EXTRA_OECONF += "--with-libelf=${STAGING_DIR_TARGET} --without-rpm \
11 --without-nss --without-avahi --without-dyninst \
12 --disable-server --disable-grapher --enable-prologues \
Brad Bishop37a0e4d2017-12-04 01:01:44 -050013 --with-python3 --without-python2-probes \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050014 ac_cv_prog_have_javac=no \
15 ac_cv_prog_have_jar=no "
16
17STAP_DOCS ?= "--disable-docs --disable-publican --disable-refdocs"
18
19EXTRA_OECONF += "${STAP_DOCS} "
20
Brad Bishop37a0e4d2017-12-04 01:01:44 -050021PACKAGECONFIG ??= "sqlite monitor python3-probes"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050022PACKAGECONFIG[libvirt] = "--enable-libvirt,--disable-libvirt,libvirt"
Patrick Williamsc0f7c042017-02-23 20:41:17 -060023PACKAGECONFIG[sqlite] = "--enable-sqlite,--disable-sqlite,sqlite3"
24PACKAGECONFIG[monitor] = "--enable-monitor,--disable-monitor,ncurses json-c"
Brad Bishop37a0e4d2017-12-04 01:01:44 -050025PACKAGECONFIG[python3-probes] = "--with-python3-probes,--without-python3-probes,python3-setuptools-native"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050026
Brad Bishop37a0e4d2017-12-04 01:01:44 -050027inherit autotools gettext pkgconfig distutils3-base
Patrick Williamsc124f4f2015-09-15 14:41:29 -050028
Brad Bishop6e60e8b2018-02-01 10:27:11 -050029BBCLASSEXTEND = "nativesdk"