blob: bb323478807585a9c04ab5c4a1473be9b98aaa72 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "The GPL Ghostscript PostScript/PDF interpreter"
2DESCRIPTION = "Ghostscript is used for PostScript/PDF preview and printing. Usually as \
3a back-end to a program such as ghostview, it can display PostScript and PDF \
4documents in an X11 environment. \
5\
6Furthermore, it can render PostScript and PDF files as graphics to be printed \
7on non-PostScript printers. Supported printers include common \
8dot-matrix, inkjet and laser models. \
9"
10HOMEPAGE = "http://www.ghostscript.com"
11SECTION = "console/utils"
12
13LICENSE = "GPLv3"
14LIC_FILES_CHKSUM = "file://LICENSE;md5=70dc2bac4d0ce4448da873cd86b123fc"
15
16DEPENDS = "ghostscript-native tiff jpeg fontconfig cups libpng"
17DEPENDS_class-native = "libpng-native"
18
19UPSTREAM_CHECK_URI = "https://github.com/ArtifexSoftware/ghostpdl-downloads/releases"
20UPSTREAM_CHECK_REGEX = "(?P<pver>\d+(\.\d+)+)\.tar"
21
Brad Bishopa5c52ff2018-11-23 10:55:50 +130022SRC_URI_BASE = "https://github.com/ArtifexSoftware/ghostpdl-downloads/releases/download/gs926/${BPN}-${PV}.tar.gz \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080023 file://ghostscript-9.15-parallel-make.patch \
24 file://ghostscript-9.16-Werror-return-type.patch \
25 file://do-not-check-local-libpng-source.patch \
26 file://avoid-host-contamination.patch \
27 file://mkdir-p.patch \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080028"
29
30SRC_URI = "${SRC_URI_BASE} \
31 file://ghostscript-9.21-prevent_recompiling.patch \
32 file://ghostscript-9.02-genarch.patch \
33 file://objarch.h \
34 file://cups-no-gcrypt.patch \
Brad Bishopd89cb5f2019-04-10 09:02:41 -040035 file://CVE-2019-6116-0001.patch \
36 file://CVE-2019-6116-0002.patch \
37 file://CVE-2019-6116-0003.patch \
38 file://CVE-2019-6116-0004.patch \
39 file://CVE-2019-6116-0005.patch \
40 file://CVE-2019-6116-0006.patch \
41 file://CVE-2019-6116-0007.patch \
42 file://CVE-2019-3835-0001.patch \
43 file://CVE-2019-3835-0002.patch \
44 file://CVE-2019-3835-0003.patch \
45 file://CVE-2019-3835-0004.patch \
46 file://CVE-2019-3838-0001.patch \
47 file://CVE-2019-3838-0002.patch \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080048 "
49
50SRC_URI_class-native = "${SRC_URI_BASE} \
51 file://ghostscript-9.21-native-fix-disable-system-libtiff.patch \
52 file://base-genht.c-add-a-preprocessor-define-to-allow-fope.patch \
53 "
54
Brad Bishopa5c52ff2018-11-23 10:55:50 +130055SRC_URI[md5sum] = "806bc2dedbc7f69b003f536658e08d4a"
56SRC_URI[sha256sum] = "831fc019bd477f7cc2d481dc5395ebfa4a593a95eb2fe1eb231a97e450d7540d"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080057
58# Put something like
59#
60# PACKAGECONFIG_append_pn-ghostscript = " x11"
61#
62# in local.conf to enable building with X11. Be careful. The order
63# of the overrides matters!
64#
65#PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11', '', d)}"
66PACKAGECONFIG_class-native = ""
67
68PACKAGECONFIG[x11] = "--with-x --x-includes=${STAGING_INCDIR} --x-libraries=${STAGING_LIBDIR}, \
69 --without-x, virtual/libx11 libxext libxt gtk+3\
70 "
71
72EXTRA_OECONF = "--with-system-libtiff --without-jbig2dec \
73 --with-fontpath=${datadir}/fonts \
74 --without-libidn --with-cups-serverbin=${exec_prefix}/lib/cups \
75 --with-cups-datadir=${datadir}/cups \
76 CUPSCONFIG="${STAGING_BINDIR_CROSS}/cups-config" \
77 "
78
79EXTRA_OECONF_append_mipsarcho32 = " --with-large_color_index=0"
80
81# Explicity disable libtiff, fontconfig,
82# freetype, cups for ghostscript-native
83EXTRA_OECONF_class-native = "--without-x --with-system-libtiff=no \
84 --without-jbig2dec \
85 --with-fontpath=${datadir}/fonts \
86 --without-libidn --disable-fontconfig \
87 --disable-freetype --disable-cups"
88
89# This has been fixed upstream but for now we need to subvert the check for time.h
90# http://bugs.ghostscript.com/show_bug.cgi?id=692443
91# http://bugs.ghostscript.com/show_bug.cgi?id=692426
92CFLAGS += "-DHAVE_SYS_TIME_H=1"
93BUILD_CFLAGS += "-DHAVE_SYS_TIME_H=1"
94
95inherit autotools
96
97do_configure_prepend () {
98 mkdir -p obj
99 mkdir -p soobj
100 if [ -e ${WORKDIR}/objarch.h ]; then
101 cp ${WORKDIR}/objarch.h obj/arch.h
102 fi
103}
104
105do_configure_append () {
106 # copy tools from the native ghostscript build
107 if [ "${PN}" != "ghostscript-native" ]; then
108 mkdir -p obj/aux soobj
109 for i in genarch genconf mkromfs echogs gendev genht packps; do
110 cp ${STAGING_BINDIR_NATIVE}/ghostscript-${PV}/$i obj/aux/$i
111 done
112 fi
113}
114
115do_install_append () {
116 mkdir -p ${D}${datadir}/ghostscript/${PV}/
117 cp -r ${S}/Resource ${D}${datadir}/ghostscript/${PV}/
118 cp -r ${S}/iccprofiles ${D}${datadir}/ghostscript/${PV}/
119}
120
121do_compile_class-native () {
122 mkdir -p obj
123 for i in genarch genconf mkromfs echogs gendev genht packps; do
124 oe_runmake obj/aux/$i
125 done
126}
127
128do_install_class-native () {
129 install -d ${D}${bindir}/ghostscript-${PV}
130 for i in genarch genconf mkromfs echogs gendev genht packps; do
131 install -m 755 obj/aux/$i ${D}${bindir}/ghostscript-${PV}/$i
132 done
133}
134
135BBCLASSEXTEND = "native"
136
137# ghostscript does not supports "arc"
138COMPATIBLE_HOST = "^(?!arc).*"