Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | require libtool-${PV}.inc |
| 2 | |
| 3 | RDEPENDS_${PN} += "bash" |
| 4 | |
| 5 | # |
| 6 | # We want the results of libtool-cross preserved - don't stage anything ourselves. |
| 7 | # |
| 8 | SYSROOT_PREPROCESS_FUNCS += "libtool_sysroot_preprocess" |
| 9 | |
| 10 | do_install_append () { |
| 11 | sed -e 's@--sysroot=${STAGING_DIR_HOST}@@g' \ |
| 12 | -e 's@${STAGING_DIR_HOST}@@g' \ |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame^] | 13 | -e 's@${STAGING_DIR_NATIVE}@@g' \ |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 14 | -e 's@^\(sys_lib_search_path_spec="\).*@\1${libdir} ${base_libdir}"@' \ |
| 15 | -e 's@^\(compiler_lib_search_dirs="\).*@\1${libdir} ${base_libdir}"@' \ |
| 16 | -e 's@^\(compiler_lib_search_path="\).*@\1${libdir} ${base_libdir}"@' \ |
| 17 | -e 's@^\(predep_objects="\).*@\1"@' \ |
| 18 | -e 's@^\(postdep_objects="\).*@\1"@' \ |
| 19 | -i ${D}${bindir}/libtool |
| 20 | } |
| 21 | |
| 22 | libtool_sysroot_preprocess () { |
| 23 | rm -rf ${SYSROOT_DESTDIR}${bindir}/* |
| 24 | rm -rf ${SYSROOT_DESTDIR}${datadir}/aclocal/* |
| 25 | rm -rf ${SYSROOT_DESTDIR}${datadir}/libtool/build-aux/* |
| 26 | } |
| 27 | |