Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame^] | 1 | SUMMARY = "Extends Python unittest to make testing easier" |
| 2 | DESCRIPTION = "nose extends the test loading and running features of unittest, \ |
| 3 | making it easier to write, find and run tests." |
| 4 | SECTION = "devel/python" |
| 5 | LICENSE = "LGPLv2.1" |
| 6 | LIC_FILES_CHKSUM = "file://lgpl.txt;md5=a6f89e2100d9b6cdffcea4f398e37343" |
| 7 | |
| 8 | SRC_URI = "http://pypi.python.org/packages/source/n/nose/nose-${PV}.tar.gz" |
| 9 | |
| 10 | SRC_URI[md5sum] = "4d3ad0ff07b61373d2cefc89c5d0b20b" |
| 11 | SRC_URI[sha256sum] = "f1bffef9cbc82628f6e7d7b40d7e255aefaa1adb6a1b1d26c69a8b79e6208a98" |
| 12 | |
| 13 | UPSTREAM_CHECK_URI = "https://pypi.python.org/pypi/nose/" |
| 14 | UPSTREAM_CHECK_REGEX = "/nose/(?P<pver>(\d+[\.\-_]*)+)" |
| 15 | |
| 16 | S = "${WORKDIR}/nose-${PV}" |
| 17 | |
| 18 | inherit setuptools |
| 19 | |
| 20 | RDEPENDS_${PN} = "\ |
| 21 | python-unittest \ |
| 22 | " |
| 23 | |
| 24 | BBCLASSEXTEND = "native nativesdk" |