blob: 0856c190a4423e141c0706f9baec8293a68bc3f1 [file] [log] [blame]
Patrick Williamsd8c66bc2016-06-20 12:57:21 -05001SUMMARY = "XCB: The X protocol C binding library"
2DESCRIPTION = "The X protocol C-language Binding (XCB) is a replacement \
3for Xlib featuring a small footprint, latency hiding, direct access to \
4the protocol, improved threading support, and extensibility."
5HOMEPAGE = "http://xcb.freedesktop.org"
6BUGTRACKER = "https://bugs.freedesktop.org/enter_bug.cgi?product=XCB"
7SECTION = "x11/libs"
8
9LICENSE = "MIT"
10LIC_FILES_CHKSUM = "file://COPYING;md5=d763b081cb10c223435b01e00dc0aba7"
11
12SRC_URI = "http://xcb.freedesktop.org/dist/libxcb-${PV}.tar.bz2 \
13 file://xcbincludedir.patch \
14 file://disable-check.patch \
15 file://gcc-mips-pr68302-mips-workaround.patch \
16 "
17SRC_URI[md5sum] = "f97a65e6158775de518ac391935634c2"
18SRC_URI[sha256sum] = "b720fd6c7d200e5371affdb3f049cc8f88cff9aed942ff1b824d95eedbf69d30"
19
20BBCLASSEXTEND = "native nativesdk"
21
22DEPENDS = "xcb-proto xproto libxau libpthread-stubs libxdmcp"
23
24PACKAGES_DYNAMIC = "^libxcb-.*"
25
26FILES_${PN} = "${libdir}/libxcb.so.*"
27
28inherit autotools pkgconfig distro_features_check
29
30# The libxau and others requires x11 in DISTRO_FEATURES
31REQUIRED_DISTRO_FEATURES = "x11"
32REQUIRED_DISTRO_FEATURES_class-native = ""
33
34python populate_packages_prepend () {
35 do_split_packages(d, '${libdir}', '^libxcb-(.*)\.so\..*$', 'libxcb-%s', 'XCB library module for %s', allow_links=True)
36}