blob: dad252b4ed3b12e90fbdb2d2a34ea7dedb1a9b9b [file] [log] [blame]
Patrick Williamsc0f7c042017-02-23 20:41:17 -06001SUMMARY = "Real-Time preemption testcases"
2HOMEPAGE = "https://rt.wiki.kernel.org/index.php/Cyclictest"
3SECTION = "tests"
4DEPENDS = "linux-libc-headers virtual/libc"
5LICENSE = "GPLv2 & GPLv2+"
6LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe \
7 file://src/cyclictest/cyclictest.c;beginline=7;endline=9;md5=e768b8da44555fe63f65e5c497844cb5 \
8 file://src/pi_tests/pi_stress.c;beginline=6;endline=19;md5=bd426a634a43ec612e9fbf125dfcc949"
9
10require rt-tests.inc
11inherit ptest
12
13SRC_URI += " \
14 file://run-ptest \
15 file://rt_bmark.py \
Andrew Geissler82c905d2020-04-13 13:39:40 -050016 file://0001-gzip-with-n-for-build-reproducibilty.patch \
Patrick Williamsc0f7c042017-02-23 20:41:17 -060017 "
Brad Bishop79641f22019-09-10 07:20:22 -040018
19# rt-tests needs PI mutex support in libc
20COMPATIBLE_HOST_libc-musl = 'null'
21
Patrick Williamsc0f7c042017-02-23 20:41:17 -060022# Do not install hwlatdetect
23EXTRA_OEMAKE += "PYLIB=''"
24
25do_install() {
26 oe_runmake install DESTDIR=${D} SBINDIR=${sbindir} MANDIR=${mandir} \
27 INCLUDEDIR=${includedir}
28}
29
30do_install_ptest() {
31 cp ${WORKDIR}/rt_bmark.py ${D}${PTEST_PATH}
32}
33
Brad Bishop08902b02019-08-20 09:16:51 -040034RDEPENDS_${PN}-ptest += " stress-ng python3 python3-multiprocessing python3-datetime python3-misc"
Patrick Williamsc0f7c042017-02-23 20:41:17 -060035
36FILES_${PN} += "${prefix}/src/backfire"