blob: 5ab5057d86124f9572c4e5df6301ebf5b61ad080 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001require ttf.inc
2
3SUMMARY = "Adobe OpenType Pan-CJK font family for Korean"
4HOMEPAGE = "https://github.com/adobe-fonts/source-han-sans"
5LICENSE = "OFL-1.1"
Patrick Williamsdb4c27e2022-08-05 08:10:29 -05006LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/${LICENSE};md5=fac3a519e5e9eb96316656e0ca4f2b90"
Patrick Williamsb48b7b42016-08-17 15:04:38 -05007
8inherit allarch fontcache
9
10# Download tends to break - so - or not?
11#EXCLUDE_FROM_WORLD = "1"
12
13SRC_URI = " \
Patrick Williamsdb4c27e2022-08-05 08:10:29 -050014 svn://github.com/adobe-fonts/source-han-sans;module=branches/release/SubsetOTF/TW;protocol=http;rev=82 \
Patrick Williamsb48b7b42016-08-17 15:04:38 -050015 file://44-source-han-sans-kr.conf \
16"
17SRC_URI[md5sum] = "f8d1bd6c87d8575afdb25e2f46bd81d4"
18SRC_URI[sha256sum] = "38fd15c80f9980492faaa1af39ff873d8a38e45027023fb17d5b10d4b4b0e6af"
19
20S = "${WORKDIR}/SourceHanSansKR"
21
22do_install() {
23 install -d ${D}${sysconfdir}/fonts/conf.d/
24 install -m 0644 ${WORKDIR}/44-source-han-sans-kr.conf ${D}${sysconfdir}/fonts/conf.d/
25
26 install -d ${D}${datadir}/fonts/truetype/
27 find ./ -name '*.otf' -exec install -m 0644 {} ${D}${datadir}/fonts/truetype/ \;
28}
29
Patrick Williams213cb262021-08-07 19:21:33 -050030FILES:${PN} = " \
Patrick Williamsb48b7b42016-08-17 15:04:38 -050031 ${sysconfdir}/fonts \
32 ${datadir}/fonts \
33"
34