blob: b1d2abde73dd4ca87ffcb41f827fe57ee52fd906 [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "Monitor for system resources and process activity"
2DESCRIPTION = "Atop is an ASCII full-screen performance monitor for Linux that \
3is capable of reporting the activity of all processes (even if processes have \
4finished during the interval), daily logging of system and process activity for \
5long-term analysis, highlighting overloaded system resources by using colors, \
6etc. At regular intervals, it shows system-level activity related to the CPU, \
7memory, swap, disks (including LVM) and network layers, and for every process \
8(and thread) it shows e.g. the CPU utilization, memory growth, disk \
9utilization, priority, username, state, and exit code."
10HOMEPAGE = "http://www.atoptool.nl"
11SECTION = "console/utils"
12
Andrew Geissler9aee5002022-03-30 16:27:02 +000013LICENSE = "GPL-2.0-only"
Brad Bishop19323692019-04-05 15:28:33 -040014LIC_FILES_CHKSUM = "file://COPYING;md5=393a5ca445f6965873eca0259a17f833"
15
16DEPENDS = "ncurses zlib"
17
18SRC_URI = "http://www.atoptool.nl/download/${BP}.tar.gz \
19 ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'file://volatiles.atop.conf', 'file://volatiles.99_atop', d)} \
20 file://fix-permissions.patch \
21 file://sysvinit-implement-status.patch \
22 file://0001-atop.daily-atop.init-atop-pm.sh-Avoid-using-bash.patch \
23 "
24SRC_URI[md5sum] = "1077da884ed94f2bc3c81ac3ab970436"
25SRC_URI[sha256sum] = "be1c010a77086b7d98376fce96514afcd73c3f20a8d1fe01520899ff69a73d69"
26
Patrick Williamsdb4c27e2022-08-05 08:10:29 -050027CVE_CHECK_IGNORE += "\
28 CVE-2011-3618 \
29"
30
Brad Bishop19323692019-04-05 15:28:33 -040031do_compile() {
32 oe_runmake all
33}
34
35do_install() {
36 if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
37 make DESTDIR=${D} VERS=${PV} SYSDPATH=${systemd_system_unitdir} \
38 PMPATHD=${systemd_unitdir}/system-sleep systemdinstall
39 install -d ${D}${sysconfdir}/tmpfiles.d
40 install -m 644 ${WORKDIR}/volatiles.atop.conf ${D}${sysconfdir}/tmpfiles.d/atop.conf
41 rm -f ${D}${systemd_system_unitdir}/atopacct.service
42 else
43 make DESTDIR=${D} VERS=${PV} sysvinstall
44 install -d ${D}${sysconfdir}/default/volatiles
45 install -m 644 ${WORKDIR}/volatiles.99_atop ${D}${sysconfdir}/default/volatiles/99_atop
46 rm -f ${D}${sysconfdir}/init.d/atopacct
47 fi
48
Andrew Geissler595f6302022-01-24 19:11:47 +000049 # /var/log/atop will be created in runtime
50 rm -rf ${D}${localstatedir}/log
51 rmdir --ignore-fail-on-non-empty ${D}${localstatedir}
52
Brad Bishop19323692019-04-05 15:28:33 -040053 # remove atopacct related files
54 rm -rf ${D}${sbindir} ${D}${mandir}/man8
55}
56
57inherit systemd
58
Patrick Williams213cb262021-08-07 19:21:33 -050059SYSTEMD_SERVICE:${PN} = "atop.service atopgpu.service"
Brad Bishop19323692019-04-05 15:28:33 -040060SYSTEMD_AUTO_ENABLE = "disable"
61
Patrick Williams213cb262021-08-07 19:21:33 -050062FILES:${PN} += "${systemd_unitdir}/system-sleep"
Brad Bishop19323692019-04-05 15:28:33 -040063
Patrick Williams213cb262021-08-07 19:21:33 -050064RDEPENDS:${PN} = "procps"