blob: 71f3d3594e7f6adfa5374767d924b80f773406d7 [file] [log] [blame]
Andrew Geissler69721092021-07-23 12:57:00 -04001# Copyright (C) 2021 Khem Raj <raj.khem@gmail.com>
2# Released under the MIT license (see COPYING.MIT for the terms)
3
Patrick Williamsdb4c27e2022-08-05 08:10:29 -05004SUMMARY = "An aspect-oriented programming, monkey-patch and decorators library."
5DESCRIPTION = " It is useful when changing behavior in existing code is desired. \
6It includes tools for debugging and testing: simple mock/record and a complete capture/replay framework."
Andrew Geissler69721092021-07-23 12:57:00 -04007HOMEPAGE = "https://github.com/ionelmc/python-aspectlib"
8LICENSE = "BSD-2-Clause"
9LIC_FILES_CHKSUM = "file://LICENSE;md5=d58b3f20fd10347a9458b8a03793b62e"
10
11SRC_URI[sha256sum] = "d275ec82c4c2712e564bb760e4accff8f061f648e38774feabeb8b241cf3a4aa"
12
13inherit ptest pypi setuptools3
14
15SRC_URI += "file://run-ptest \
16 file://0001-Remove-tornado-6-test-constraint.-Ref-15.patch \
17 "
18
19do_install_ptest() {
20 install -d ${D}${PTEST_PATH}/tests
21 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
22}
23
Patrick Williams213cb262021-08-07 19:21:33 -050024RDEPENDS:${PN}-ptest += "\
Andrew Geissler69721092021-07-23 12:57:00 -040025 python3-tornado \
26 python3-process-tests \
27"
28
Patrick Williams213cb262021-08-07 19:21:33 -050029RDEPENDS:${PN} += "python3-core python3-fields"
Andrew Geissler69721092021-07-23 12:57:00 -040030
31BBCLASSEXTEND = "native nativesdk"