blob: ea17e84143f80544a1ce691c9b61ddd0c8d0c459 [file] [log] [blame]
Andrew Geissler69721092021-07-23 12:57:00 -04001# Copyright (C) 2021 Khem Raj <raj.khem@gmail.com>
2# Released under the MIT license (see COPYING.MIT for the terms)
3
4SUMMARY = "execnet: rapid multi-Python deployment"
5HOMEPAGE = "https://execnet.readthedocs.io/en/latest/"
6LICENSE = "MIT"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=772fcdaca14b378878d05c7d857e6c3e"
8
Andrew Geissler595f6302022-01-24 19:11:47 +00009DEPENDS += "\
10 python3-pip-native \
11 python3-setuptools-scm-native \
12"
Andrew Geissler69721092021-07-23 12:57:00 -040013
14SRC_URI += "file://run-ptest \
15 "
16SRC_URI[sha256sum] = "8f694f3ba9cc92cab508b152dcfe322153975c29bda272e2fd7f3f00f36e47c5"
17
18inherit ptest pypi setuptools3
19
20do_install_ptest() {
21 install -d ${D}${PTEST_PATH}/tests
22 cp -rf ${S}/testing/* ${D}${PTEST_PATH}/tests/
23}
24
Patrick Williams213cb262021-08-07 19:21:33 -050025RDEPENDS:${PN}-ptest += "\
Andrew Geissler69721092021-07-23 12:57:00 -040026 python3-pytest \
27"
28
Patrick Williams213cb262021-08-07 19:21:33 -050029RDEPENDS:${PN} += "python3-core python3-crypt python3-ctypes python3-fcntl python3-io python3-shell python3-threading"
Andrew Geissler69721092021-07-23 12:57:00 -040030
31BBCLASSEXTEND = "native nativesdk"