blob: 2a8b8730c42fd86f72090047b00977b534d90a0e [file] [log] [blame]
Andrew Geisslerc87764f2020-06-27 00:16:32 -05001SUMMARY = "Run a subprocess in a pseudo terminal"
2HOMEPAGE = "http://ptyprocess.readthedocs.io/en/latest/"
3SECTION = "devel/python"
4LICENSE = "ISC"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=cfdcd51fa7d5808da4e74346ee394490"
6
7SRCNAME = "ptyprocess"
8
Andrew Geisslereef63862021-01-29 15:58:13 -06009SRC_URI[sha256sum] = "5c5d0a3b48ceee0b48485e0c26037c0acd7d29765ca3fbb5cb3831d347423220"
Andrew Geisslerc87764f2020-06-27 00:16:32 -050010
Andrew Geissler9aee5002022-03-30 16:27:02 +000011inherit pypi python_flit_core
Andrew Geisslerc87764f2020-06-27 00:16:32 -050012
13UPSTREAM_CHECK_URI = "https://pypi.python.org/pypi/ptyprocess"
14
15S = "${WORKDIR}/${SRCNAME}-${PV}"
16
Patrick Williams213cb262021-08-07 19:21:33 -050017RDEPENDS:${PN} = "\
Andrew Geisslerc87764f2020-06-27 00:16:32 -050018 ${PYTHON_PN}-core \
19 ${PYTHON_PN}-fcntl \
20 ${PYTHON_PN}-terminal \
21 ${PYTHON_PN}-resource \
22"
23
24BBCLASSEXTEND = "native nativesdk"
25
26inherit ptest
27
28SRC_URI += " \
29 file://run-ptest \
30"
31
Patrick Williams213cb262021-08-07 19:21:33 -050032RDEPENDS:${PN}-ptest += " \
Andrew Geisslerc87764f2020-06-27 00:16:32 -050033 ${PYTHON_PN}-pytest \
34 ${PYTHON_PN}-fcntl \
35 ${PYTHON_PN}-terminal \
36 ${PYTHON_PN}-resource \
Patrick Williamsdb4c27e2022-08-05 08:10:29 -050037 bash \
Andrew Geisslerc87764f2020-06-27 00:16:32 -050038"
39
40do_install_ptest() {
41 install -d ${D}${PTEST_PATH}/tests
42 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
43}