blob: 45f19d177c282797abed26da1e57fb240ece00ca [file] [log] [blame]
Andrew Geissler9aee5002022-03-30 16:27:02 +00001SUMMARY = "AppArmor another MAC control system"
2DESCRIPTION = "user-space parser utility for AppArmor \
3 This provides the system initialization scripts needed to use the \
4 AppArmor Mandatory Access Control system, including the AppArmor Parser \
5 which is required to convert AppArmor text profiles into machine-readable \
6 policies that are loaded into the kernel for use with the AppArmor Linux \
7 Security Module."
8HOMEAPAGE = "http://apparmor.net/"
9SECTION = "admin"
10
Patrick Williams03907ee2022-05-01 06:28:52 -050011LICENSE = "GPL-2.0-only & GPL-2.0-or-later & BSD-3-Clause & LGPL-2.1-or-later"
Andrew Geissler9aee5002022-03-30 16:27:02 +000012LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=fd57a4b0bc782d7b80fd431f10bbf9d0"
13
14DEPENDS = "bison-native apr gettext-native coreutils-native swig-native"
15
16SRC_URI = " \
17 git://gitlab.com/apparmor/apparmor.git;protocol=https;branch=apparmor-3.0 \
18 file://run-ptest \
19 file://crosscompile_perl_bindings.patch \
20 file://0001-Makefile.am-suppress-perllocal.pod.patch \
21 file://0001-Makefile-fix-hardcoded-installation-directories.patch \
22 file://0001-rc.apparmor.debian-add-missing-functions.patch \
23 "
24
Patrick Williamsdb4c27e2022-08-05 08:10:29 -050025SRCREV = "822db765c6fa7f9de7233c4011254a82d4dafe76"
Andrew Geissler9aee5002022-03-30 16:27:02 +000026S = "${WORKDIR}/git"
27
28PARALLEL_MAKE = ""
29
30COMPATIBLE_MACHINE:mips64 = "(!.*mips64).*"
31
32inherit pkgconfig autotools-brokensep update-rc.d python3native python3targetconfig perlnative cpan systemd features_check bash-completion setuptools3
33
34REQUIRED_DISTRO_FEATURES = "apparmor"
35
36PACKAGECONFIG ?= "python perl aa-decode"
37PACKAGECONFIG[manpages] = "--enable-man-pages, --disable-man-pages"
38PACKAGECONFIG[python] = "--with-python, --without-python, python3 , python3-core python3-modules"
39PACKAGECONFIG[perl] = "--with-perl, --without-perl, "
40PACKAGECONFIG[apache2] = ",,apache2,"
41PACKAGECONFIG[aa-decode] = ",,,bash"
42
43python() {
44 if 'apache2' in d.getVar('PACKAGECONFIG').split() and \
45 'webserver' not in d.getVar('BBFILE_COLLECTIONS').split():
46 raise bb.parse.SkipRecipe('Requires meta-webserver to be present.')
47}
48
49DISABLE_STATIC = ""
50
51do_configure() {
52 cd ${S}/libraries/libapparmor
53 aclocal
54 autoconf --force
55 libtoolize --automake -c --force
56 automake -ac
57 ./configure ${CONFIGUREOPTS} ${EXTRA_OECONF}
58}
59
60do_compile () {
61 sed -i "s@sed -ie 's///g' Makefile.perl@@" ${S}/libraries/libapparmor/swig/perl/Makefile
62 oe_runmake -C ${B}/libraries/libapparmor
63 oe_runmake -C ${B}/binutils
64 oe_runmake -C ${B}/utils
65 oe_runmake -C ${B}/parser
66 oe_runmake -C ${B}/profiles
67
68 if ${@bb.utils.contains('PACKAGECONFIG','apache2','true','false', d)}; then
69 oe_runmake -C ${B}/changehat/mod_apparmor
70 fi
71
72 if ${@bb.utils.contains('DISTRO_FEATURES', 'pam', 'true', 'false', d)}; then
73 oe_runmake -C ${B}/changehat/pam_apparmor
74 fi
75}
76
77do_install () {
78 oe_runmake -C ${B}/libraries/libapparmor DESTDIR="${D}" install
79 oe_runmake -C ${B}/binutils DESTDIR="${D}" install
80 oe_runmake -C ${B}/utils DESTDIR="${D}" install
81 oe_runmake -C ${B}/parser DESTDIR="${D}" install
82 oe_runmake -C ${B}/profiles DESTDIR="${D}" install
83
84 if ! ${@bb.utils.contains('PACKAGECONFIG','aa-decode','true','false', d)}; then
85 rm -f ${D}${sbindir}/aa-decode
86 fi
87
88 if ${@bb.utils.contains('PACKAGECONFIG','apache2','true','false', d)}; then
89 oe_runmake -C ${B}/changehat/mod_apparmor DESTDIR="${D}" install
90 fi
91
92 if ${@bb.utils.contains('DISTRO_FEATURES', 'pam', 'true', 'false', d)}; then
93 oe_runmake -C ${B}/changehat/pam_apparmor DESTDIR="${D}" install
94 fi
95
96 if ${@bb.utils.contains('DISTRO_FEATURES','sysvinit','true','false',d)}; then
97 install -d ${D}${sysconfdir}/init.d
98 install -m 755 ${B}/parser/rc.apparmor.debian ${D}${sysconfdir}/init.d/apparmor
99 fi
100
101 if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then
102 oe_runmake -C ${B}/parser DESTDIR="${D}" install-systemd
103 fi
Andrew Geissler615f2f12022-07-15 14:00:58 -0500104 chown root:root -R ${D}/${sysconfdir}/apparmor.d
105 chown root:root -R ${D}/${datadir}/apparmor
Andrew Geissler9aee5002022-03-30 16:27:02 +0000106}
107
108#Building ptest on arm fails.
109do_compile_ptest:aarch64 () {
110 :
111}
112
113do_compile_ptest:arm () {
114 :
115}
116
117do_compile_ptest () {
118 sed -i -e 's/cpp \-dM/${HOST_PREFIX}gcc \-dM/' ${B}/tests/regression/apparmor/Makefile
119 oe_runmake -C ${B}/tests/regression/apparmor USE_SYSTEM=0
120 oe_runmake -C ${B}/libraries/libapparmor
121}
122
123do_install_ptest () {
124 t=${D}/${PTEST_PATH}/testsuite
125 install -d ${t}
126 install -d ${t}/tests/regression/apparmor
127 cp -rf ${B}/tests/regression/apparmor ${t}/tests/regression
128
129 cp ${B}/parser/apparmor_parser ${t}/parser
130 cp ${B}/parser/frob_slack_rc ${t}/parser
131
132 install -d ${t}/libraries/libapparmor
133 cp -rf ${B}/libraries/libapparmor ${t}/libraries
134
135 install -d ${t}/common
136 cp -rf ${B}/common ${t}
137
138 install -d ${t}/binutils
139 cp -rf ${B}/binutils ${t}
140}
141
142#Building ptest on arm fails.
143do_install_ptest:aarch64 () {
144 :
145}
146
147do_install_ptest:arm() {
148 :
149}
150
151INITSCRIPT_PACKAGES = "${PN}"
152INITSCRIPT_NAME = "apparmor"
153INITSCRIPT_PARAMS = "start 16 2 3 4 5 . stop 35 0 1 6 ."
154
155SYSTEMD_PACKAGES = "${PN}"
156SYSTEMD_SERVICE:${PN} = "apparmor.service"
157SYSTEMD_AUTO_ENABLE ?= "enable"
158
159PACKAGES += "mod-${PN}"
160
161FILES:${PN} += "${nonarch_base_libdir}/apparmor/ ${base_libdir}/security/ ${sysconfdir}/apparmor ${nonarch_libdir}/${PYTHON_DIR}/site-packages"
162FILES:mod-${PN} = "${libdir}/apache2/modules/*"
163FILES:${PN}-dbg += "${base_libdir}/security/.debug"
164
165DEPENDS:append:libc-musl = " fts "
166RDEPENDS:${PN}:libc-musl += "musl-utils"
167RDEPENDS:${PN}:libc-glibc += "glibc-utils"
168
169# Add coreutils and findutils only if sysvinit scripts are in use
170RDEPENDS:${PN} += "${@["coreutils findutils", ""][(d.getVar('VIRTUAL-RUNTIME_init_manager') == 'systemd')]} ${@bb.utils.contains('PACKAGECONFIG','python','python3-core python3-modules','', d)}"
171RDEPENDS:${PN}:remove = "${@bb.utils.contains('PACKAGECONFIG','perl','','perl', d)}"
172RDEPENDS:${PN}-ptest += "perl coreutils dbus-lib bash"
173
174INSANE_SKIP:${PN} = "ldflags"
175PRIVATE_LIBS:${PN}-ptest = "libapparmor.so*"