blob: 42625fa041f20fe569f6767bd1d51c4acc738223 [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001SUMMARY = "Tools to manipulate UEFI variables"
2DESCRIPTION = "efivar provides a simple command line interface to the UEFI variable facility"
3HOMEPAGE = "https://github.com/rhboot/efivar"
4
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00005LICENSE = "LGPL-2.1-or-later"
Andrew Geissler595f6302022-01-24 19:11:47 +00006LIC_FILES_CHKSUM = "file://COPYING;md5=6626bb1e20189cfa95f2c508ba286393"
7
8COMPATIBLE_HOST = "(i.86|x86_64|arm|aarch64).*-linux"
9
10SRC_URI = "git://github.com/rhinstaller/efivar.git;branch=main;protocol=https \
11 file://0001-docs-do-not-build-efisecdb-manpage.patch \
12 file://0001-src-Makefile-build-util.c-separately-for-makeguids.patch \
Andrew Geissler78b72792022-06-14 06:47:25 -050013 file://efisecdb-fix-build-with-musl-libc.patch \
Patrick Williamsdb4c27e2022-08-05 08:10:29 -050014 file://0001-Fix-invalid-free-in-main.patch \
Andrew Geissler595f6302022-01-24 19:11:47 +000015 "
16SRCREV = "1753149d4176ebfb2b135ac0aaf79340bf0e7a93"
17
18S = "${WORKDIR}/git"
19
20inherit pkgconfig
21
22export CCLD_FOR_BUILD = "${BUILD_CCLD}"
23
24# Upstream uses --add-needed in gcc.specs which gold doesn't support, so
25# enforce BFD.
26LDFLAGS += "-fuse-ld=bfd"
27
28do_compile() {
29 oe_runmake ERRORS= HOST_CFLAGS="${BUILD_CFLAGS}" HOST_LDFLAGS="${BUILD_LDFLAGS}"
30}
31
32do_install() {
33 oe_runmake install DESTDIR=${D}
34}
35
36BBCLASSEXTEND = "native"
37
38RRECOMMENDS:${PN}:class-target = "kernel-module-efivarfs"
39
40CLEANBROKEN = "1"