blob: 7f349f673da6b1d2234a918a32a2d42439ed7202 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "Integrated Development Environment support"
2DESCRIPTION = "Meta package for ensuring the build directory contains all appropriate toolchain packages for using an IDE"
3LICENSE = "MIT"
Patrick Williamsc124f4f2015-09-15 14:41:29 -05004
Patrick Williamsdb4c27e2022-08-05 08:10:29 -05005DEPENDS = "virtual/libc gdb-cross-${TARGET_ARCH} qemu-native qemu-helper-native unfs3-native cmake-native autoconf-native automake-native meson-native intltool-native pkgconfig-native"
Patrick Williamsc124f4f2015-09-15 14:41:29 -05006PR = "r3"
Brad Bishop6e60e8b2018-02-01 10:27:11 -05007RM_WORK_EXCLUDE += "${PN}"
Patrick Williamsc124f4f2015-09-15 14:41:29 -05008
Patrick Williamsdb4c27e2022-08-05 08:10:29 -05009inherit toolchain-scripts nopackages deploy testsdk
10
11TESTSDK_CLASS_NAME = "oeqa.sdk.testmetaidesupport.TestSDK"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050012
13do_populate_ide_support () {
14 toolchain_create_tree_env_script
15}
16
Andrew Geissler5199d832021-09-24 16:47:35 -050017python () {
18 sitefiles, searched = siteinfo_get_files(d, sysrootcache=False)
19 d.setVar("CONFIG_SITE", " ".join(sitefiles))
20 d.appendVarFlag("do_populate_ide_support", "file-checksums", " " + " ".join(searched))
21}
22
Patrick Williamsdb4c27e2022-08-05 08:10:29 -050023addtask populate_ide_support before do_deploy after do_install
24
25python do_write_test_data() {
26 from oe.data import export2json
27
28 out_dir = d.getVar('B')
29 testdata_name = os.path.join(out_dir, "%s.testdata.json" % d.getVar('PN'))
30
31 export2json(d, testdata_name)
32}
33addtask write_test_data before do_deploy after do_install
34
35do_deploy () {
36 install ${B}/* ${DEPLOYDIR}
37}
38
39addtask deploy before do_build
40
41do_build[deptask] += "do_prepare_recipe_sysroot"