blob: 9282d36a4dc183672cbfa6109bfaab19395d45be [file] [log] [blame]
Brad Bishop6e60e8b2018-02-01 10:27:11 -05001SUMMARY = "A meta recipe to build native tools used by wic."
2
3LICENSE = "MIT"
4
5DEPENDS = "\
Andrew Geisslerd1e89492021-02-12 15:35:20 -06006 parted-native gptfdisk-native dosfstools-native \
Andrew Geisslerd25ed322020-06-27 00:28:28 -05007 mtools-native bmap-tools-native grub-native cdrtools-native \
Brad Bishopd7bf8c12018-02-25 22:55:05 -05008 btrfs-tools-native squashfs-tools-native pseudo-native \
Patrick Williams03907ee2022-05-01 06:28:52 -05009 e2fsprogs-native util-linux-native tar-native erofs-utils-native \
Patrick Williamsdb4c27e2022-08-05 08:10:29 -050010 virtual/${TARGET_PREFIX}binutils \
Brad Bishop6e60e8b2018-02-01 10:27:11 -050011 "
Patrick Williams213cb262021-08-07 19:21:33 -050012DEPENDS:append:x86 = " syslinux-native syslinux grub-efi systemd-boot"
13DEPENDS:append:x86-64 = " syslinux-native syslinux grub-efi systemd-boot"
14DEPENDS:append:x86-x32 = " syslinux-native syslinux grub-efi"
15DEPENDS:append:aarch64 = " grub-efi systemd-boot"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050016
17INHIBIT_DEFAULT_DEPS = "1"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050018
Brad Bishop6e60e8b2018-02-01 10:27:11 -050019inherit nopackages
20
21# The sysroot of wic-tools is needed for wic, but if rm_work is enabled, it will
22# be removed before wic has a chance to use it, hence the exclusion below.
23RM_WORK_EXCLUDE += "${PN}"
24
25python do_build_sysroot () {
26 bb.build.exec_func("extend_recipe_sysroot", d)
Brad Bishop6e60e8b2018-02-01 10:27:11 -050027}
28addtask do_build_sysroot after do_prepare_recipe_sysroot before do_build